summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-16 00:11:23 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-16 00:37:43 +0100
commit275cd1bde43d7dca337e01a234ab1cc5820276fb (patch)
treed0d3cacb1bfe1bf447701be5a0202af0f3f90f96
parentvdr-plugin-2.eclass: prefix qa notices with "QA Notice:" (diff)
downloadgentoo-275cd1bde43d7dca337e01a234ab1cc5820276fb.tar.gz
gentoo-275cd1bde43d7dca337e01a234ab1cc5820276fb.tar.bz2
gentoo-275cd1bde43d7dca337e01a234ab1cc5820276fb.zip
dev-lua/lgi: mask tests for luajit
According to upstream, luakit tests are currently not working. Closes: https://bugs.gentoo.org/774270 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/lgi/lgi-0.9.2-r100.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-lua/lgi/lgi-0.9.2-r100.ebuild b/dev-lua/lgi/lgi-0.9.2-r100.ebuild
index 8c362af8788a..4fab943f27a6 100644
--- a/dev-lua/lgi/lgi-0.9.2-r100.ebuild
+++ b/dev-lua/lgi/lgi-0.9.2-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -97,9 +97,14 @@ src_compile() {
lua_src_test() {
pushd "${BUILD_DIR}" || die
- virtx \
- lgi_emake_wrapper \
- check
+
+ if [[ ${ELUA} == luajit ]]; then
+ einfo "Tests are currently not supported on LuaJIT"
+ else
+ virtx \
+ lgi_emake_wrapper \
+ check
+ fi
popd
}