summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-08-06 16:10:54 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-08-06 16:11:12 +0200
commit276b8ff0606ae89235db4a39a0b90b4c7c12b0b5 (patch)
tree60c08bf55fc72eacfd8aec10e8dda593adf2b363
parentdev-util/catfish: Bump to 4.18.0 (diff)
downloadgentoo-276b8ff0606ae89235db4a39a0b90b4c7c12b0b5.tar.gz
gentoo-276b8ff0606ae89235db4a39a0b90b4c7c12b0b5.tar.bz2
gentoo-276b8ff0606ae89235db4a39a0b90b4c7c12b0b5.zip
dev-ml/camlp5: add 8.01.00
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/camlp5/Manifest1
-rw-r--r--dev-ml/camlp5/camlp5-8.01.00.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-ml/camlp5/Manifest b/dev-ml/camlp5/Manifest
index bd4aa77f25b5..6fb7c5ddd6b6 100644
--- a/dev-ml/camlp5/Manifest
+++ b/dev-ml/camlp5/Manifest
@@ -8,3 +8,4 @@ DIST camlp5-8.00.03.tar.gz 1217877 BLAKE2B 971bd45c2740586b9883bd92f42479ae432cc
DIST camlp5-8.00.04.tar.gz 1232659 BLAKE2B 47dd18e9c518b0dccda62d054d7950dffa025a129c81eb673e6caf11f37c2af1644de861288af2ecb8e95ee4d21bf0a1d69da4fe9ed5b3d1cf3bf1012ea06d4c SHA512 0951a9528c8c9b4becf54b352a6f897cb1af26de437a137757d597a3a2ad8aef1160a3c326c9503f783bccd154d8c14a354d3a35baae2bb551611697ce4f5327
DIST camlp5-8.00.05.tar.gz 1237587 BLAKE2B 1028b1e77a048a6b2e8df4ab58171d4e182a21aa1ca01113fc0cb8b7e6f61b5db58e8c3a2f149d05c056fbd48c0c0d97e597121e4b2b55d62f1f62d80e92312b SHA512 f4cee1fba85dc3a7479929facd79d0b88f23de575107886a8d4c41cd4a0bee21ccc72f2791712635e401ca10c3ec24cfea32558eca09ba6616e01e8433c57bbe
DIST camlp5-8.00.tar.gz 1321320 BLAKE2B 14957ea83e40f3e2f68c7cbbec1ab84325eba1057f38905a37f9516a99a009024ee0b463cf588880d23d94e710b027b835dd51153a429c8bda22be7fe95dc911 SHA512 6a0d19ced4d94cd3afebfbc373d344229c5faf088e8910dea32ed4dfa841dd9844c72849f8a6281e2bce55295665eae90391cf29d062a44b083761a9e04bce93
+DIST camlp5-8.01.00.tar.gz 1249037 BLAKE2B 299308068ff0fa5e83c671103278a71f5563575caf47043071351b2c1fe833180c22c8d4a7c1d20c59d1f1550aea39a2207366a4ecc24e460f14561c2f97b9ee SHA512 70d66931f3c063870980e50da5bc98a5b7340d01c6f7026441267647dff6ed42cb155b5134e3943fbba14b0753a87a4c264662738c44ce9e4d99c4deb6f3a21d
diff --git a/dev-ml/camlp5/camlp5-8.01.00.ebuild b/dev-ml/camlp5/camlp5-8.01.00.ebuild
new file mode 100644
index 000000000000..3338ff08f328
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-8.01.00.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib vcs-clean
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="https://camlp5.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc +ocamlopt"
+
+RDEPEND="
+ dev-ml/camlp-streams:=
+ dev-ml/rresult:=
+ dev-ml/bos:=
+ dev-ml/pcre-ocaml:=
+"
+
+src_prepare() {
+ egit_clean
+ default
+}
+
+src_configure() {
+ ./configure \
+ --strict \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile() {
+ ulimit -s 11530000
+ emake out
+ if use ocamlopt; then
+ emake opt
+ emake opt.opt
+ fi
+}
+
+src_test() {
+ emake bootstrap
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META
+
+ dodoc -r doc/*
+ dodoc CHANGES DEVEL ICHANGES README.md UPGRADING MODE
+}