summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-08-19 20:18:36 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-20 15:56:01 +0300
commit276d256dc07adc0bc09f40fad68ac46a75d62ac8 (patch)
tree7b64510fc587d54d639f41260374c29a9220ca26
parentapp-laptop/msi-keyboard: New package (diff)
downloadgentoo-276d256dc07adc0bc09f40fad68ac46a75d62ac8.tar.gz
gentoo-276d256dc07adc0bc09f40fad68ac46a75d62ac8.tar.bz2
gentoo-276d256dc07adc0bc09f40fad68ac46a75d62ac8.zip
net-misc/ntpclient: fix compilation with >=linux-headers-5.2
Closes: https://bugs.gentoo.org/692544 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/12748 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-misc/ntpclient/files/ntpclient-2018.244-linux-headers-5.2.patch10
-rw-r--r--net-misc/ntpclient/ntpclient-2018.244-r1.ebuild35
2 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/ntpclient/files/ntpclient-2018.244-linux-headers-5.2.patch b/net-misc/ntpclient/files/ntpclient-2018.244-linux-headers-5.2.patch
new file mode 100644
index 000000000000..df87cb6ceb22
--- /dev/null
+++ b/net-misc/ntpclient/files/ntpclient-2018.244-linux-headers-5.2.patch
@@ -0,0 +1,10 @@
+--- a/src/ntpclient.c 2018-08-27 20:38:12.000000000 +0200
++++ b/src/ntpclient.c 2019-08-19 20:11:59.000000000 +0200
+@@ -40,6 +40,7 @@
+ #include <unistd.h>
+ #include <errno.h>
+ #ifdef PRECISION_SIOCGSTAMP
++#include <linux/sockios.h>
+ #include <sys/ioctl.h>
+ #endif
+ #ifdef USE_OBSOLETE_GETTIMEOFDAY
diff --git a/net-misc/ntpclient/ntpclient-2018.244-r1.ebuild b/net-misc/ntpclient/ntpclient-2018.244-r1.ebuild
new file mode 100644
index 000000000000..a76559041406
--- /dev/null
+++ b/net-misc/ntpclient/ntpclient-2018.244-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV/./_}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A NTP (RFC-1305 and RFC-4330) client for unix-alike systems"
+HOMEPAGE="https://github.com/troglobit/ntpclient"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug embedded obsolete +syslog"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-linux-headers-5.2.patch"
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable debug replay)
+ $(use_enable embedded mini)
+ $(use_enable obsolete)
+ $(use_enable !obsolete siocgstamp)
+ $(use_enable syslog)
+ )
+
+ econf "${myeconfargs[@]}"
+}