summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-30 22:34:31 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-30 22:55:40 +0100
commit27702248955f48d3c6cb6a4cd438cd4c6626a79d (patch)
treeccd3460a5d3b28ba2ad37fecb3b9e893627652cf
parentdev-python/wcag-contrast-ratio: New dep of pygments, v0.9 (diff)
downloadgentoo-27702248.tar.gz
gentoo-27702248.tar.bz2
gentoo-27702248.zip
dev-python/pygments: Bump to 2.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pygments/Manifest1
-rw-r--r--dev-python/pygments/pygments-2.11.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 7dc75c3a306e..1a193655cf06 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1 +1,2 @@
DIST Pygments-2.10.0.tar.gz 4052321 BLAKE2B 003d13344a2c5fe448a23d7bb45a401dc839cac10be262f5831c9547444d395811c92b74d1b18663a11a2e6cedf29b5a74cbd75267157429d61375bd9df6eb49 SHA512 28fdf35e333717795f199e0ef936d6df16ac0752324839ac36cabd2f9f6759a57663527d37f1c2f470258d63c3cf190f6dd4b631b21c849fc76575036fbdae12
+DIST Pygments-2.11.0.tar.gz 4157814 BLAKE2B de70a1de48083a9a0f281e4eb7f164cb551bd2fa2e7682c26c4513e1ebadf9da4ba6b2ccb50cc16955df484d313dff2b0431d6de2f5590c59c775f9ebd3884db SHA512 761b722cdcbc41bc730843e8120ae3c0d634db9918c1c1870d89b79002b55f245c896ed9301c44b665e573a8584d5f8504623fe9d4c63820b57a2cfcae576b33
diff --git a/dev-python/pygments/pygments-2.11.0.ebuild b/dev-python/pygments/pygments-2.11.0.ebuild
new file mode 100644
index 000000000000..0beaa1b09225
--- /dev/null
+++ b/dev-python/pygments/pygments-2.11.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1 bash-completion-r1
+
+MY_P=${P^}
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp pygmentize
+}