summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-01-21 13:28:47 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-01-21 14:29:35 +0100
commit2778e83206a9c6cc471e2a54b057c35ea3fec532 (patch)
treecfdfc00a7991d1d4047293bb9d69baa9d6ab4fbf
parentmedia-libs/gmmlib: Stabilize 22.0.0 amd64, #831653 (diff)
downloadgentoo-2778e832.tar.gz
gentoo-2778e832.tar.bz2
gentoo-2778e832.zip
app-emacs/racket-mode: new package; add version 20220120
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/racket-mode/Manifest1
-rw-r--r--app-emacs/racket-mode/files/50racket-mode-gentoo.el6
-rw-r--r--app-emacs/racket-mode/metadata.xml25
-rw-r--r--app-emacs/racket-mode/racket-mode-20220120.ebuild47
4 files changed, 79 insertions, 0 deletions
diff --git a/app-emacs/racket-mode/Manifest b/app-emacs/racket-mode/Manifest
new file mode 100644
index 000000000000..1557899778f0
--- /dev/null
+++ b/app-emacs/racket-mode/Manifest
@@ -0,0 +1 @@
+DIST racket-mode-20220120.tar.gz 286218 BLAKE2B 9786bc7a3f8127c342f90acebadef8f8468ba1cc27ad42c620554d5a478932317a2ede7061fe521a67ec0c624cea4743a1e6a50050ab2afe6e17ad220f7f7f9e SHA512 034527d62eae1c5ef09a8f5cd2bc5c5d0790bacd7ca180f0851ac6d93a3c897d4c4394d3e446285d1dbf4553fe94140656359df9b72d800202604948d9832901
diff --git a/app-emacs/racket-mode/files/50racket-mode-gentoo.el b/app-emacs/racket-mode/files/50racket-mode-gentoo.el
new file mode 100644
index 000000000000..79223161d42b
--- /dev/null
+++ b/app-emacs/racket-mode/files/50racket-mode-gentoo.el
@@ -0,0 +1,6 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'racket-mode "racket-mode"
+ "Major mode for editing Racket source files." t)
+(add-to-list 'auto-mode-alist '("\\.rkt\\'" . racket-mode))
+(add-to-list 'auto-mode-alist '("\\.rktd\\'" . racket-mode))
+(add-to-list 'auto-mode-alist '("\\.rktl\\'" . racket-mode))
diff --git a/app-emacs/racket-mode/metadata.xml b/app-emacs/racket-mode/metadata.xml
new file mode 100644
index 000000000000..f6d885ebc654
--- /dev/null
+++ b/app-emacs/racket-mode/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Emacs major and minor modes for Racket: edit, REPL, check-syntax, debug,
+ profile, and more.
+ Racket Mode uses a "back end server" written in Racket, which is
+ responsible for running files and implementing commands that cannot be
+ implemented in Emacs Lisp.
+ Details: https://github.com/greghendershott/racket-mode
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/greghendershott/racket-mode/issues</bugs-to>
+ <remote-id type="github">greghendershott/racket-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/racket-mode/racket-mode-20220120.ebuild b/app-emacs/racket-mode/racket-mode-20220120.ebuild
new file mode 100644
index 000000000000..f5a0c1b1896a
--- /dev/null
+++ b/app-emacs/racket-mode/racket-mode-20220120.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=59b227b1aab315cdaa798648e47c4c4a8f71ddba
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Emacs modes for Racket: edit, REPL, check-syntax, debug, profile, and more"
+HOMEPAGE="https://github.com/greghendershott/racket-mode/"
+SRC_URI="https://github.com/greghendershott/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${H}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-scheme/racket:="
+DEPEND="${RDEPEND}"
+
+DOCS=( CONTRIBUTING.md README.md THANKS.md )
+ELISP_TEXINFO="doc/racket-mode.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ # Equivalent to compiling from Emacs with "racket-mode-start-faster",
+ # as this is installed globally we compile it now.
+ ebegin "Compiling Racket source files"
+ find "${S}/racket" -type f -name "*.rkt" -exec raco make -v {} +
+ eend $? "failed to compile Racket source files" || die
+}
+
+src_test() {
+ emake test-racket
+}
+
+src_install() {
+ elisp_src_install
+
+ # Install Racket files
+ insinto "${SITELISP}/${PN}"
+ doins -r racket
+}