summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-01-23 13:28:18 +0100
committerSam James <sam@gentoo.org>2022-01-28 07:59:08 +0000
commit277ed0ee77a89728a2f07df98e5c8e6b65496e53 (patch)
tree4ed75bcccd0ac683f4cb4ad8bab544cdd1fdcafd
parentsys-apps/s6-portable-utils: drop 2.2.1.1, 2.2.1.2, 2.2.1.3, 2.2.2.1 (diff)
downloadgentoo-277ed0ee.tar.gz
gentoo-277ed0ee.tar.bz2
gentoo-277ed0ee.zip
sys-apps/s6-portable-utils: respect AR, CC and RANLIB
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/s6-portable-utils/s6-portable-utils-2.2.3.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/s6-portable-utils/s6-portable-utils-2.2.3.0.ebuild b/sys-apps/s6-portable-utils/s6-portable-utils-2.2.3.0.ebuild
index f7e0efbb5a78..367204b5c902 100644
--- a/sys-apps/s6-portable-utils/s6-portable-utils-2.2.3.0.ebuild
+++ b/sys-apps/s6-portable-utils/s6-portable-utils-2.2.3.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="Set of tiny portable unix utilities"
HOMEPAGE="https://www.skarnet.org/software/s6-portable-utils/"
SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
@@ -25,9 +27,13 @@ src_prepare() {
# Avoid QA warning for LDFLAGS addition; avoid overriding -fstack-protector
sed -i -e 's/.*-Wl,--hash-style=both$/:/' -e '/-fno-stack-protector$/d' \
configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
}
src_configure() {
+ tc-export AR CC RANLIB
+
econf \
--bindir=/bin \
--dynlibdir=/usr/$(get_libdir) \