summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-11-17 07:35:54 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-11-17 07:46:11 -0500
commit279d6514add37c343657783b8cfd1cb6495006b1 (patch)
treea5783dfb909606dbdd087d07dae8dd8dc6acb8d0
parentnet-fs/mc: Version bump (diff)
downloadgentoo-279d6514.tar.gz
gentoo-279d6514.tar.bz2
gentoo-279d6514.zip
net-vpn/tor: version bump to 0.3.5.5_alpha
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--net-vpn/tor/Manifest1
-rw-r--r--net-vpn/tor/tor-0.3.5.5_alpha.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-vpn/tor/Manifest b/net-vpn/tor/Manifest
index 2655668c85aa..0f777fb39dc3 100644
--- a/net-vpn/tor/Manifest
+++ b/net-vpn/tor/Manifest
@@ -4,3 +4,4 @@ DIST tor-0.3.4.8.tar.gz 6679385 BLAKE2B 9cb65442effd1cfceb34f3483a0e96de5e59e9ce
DIST tor-0.3.4.9.tar.gz 6695931 BLAKE2B ebfe0f49ae923e63b0bd8a7cafc453d7b0775cbfd167463b364490faf9bbf61decd28906d8f5bb08bfa9a5a10b371d9188a5019314c0de5ace15cc379347f88e SHA512 cc254a2cc2f21b4511e9cb215ba5f05fefc4dceffcf46a402efa2d3540872a4ed8e0095245df0802ea12c1367451bc16ca60c0aea6a77e2139580f3c5ba8c02f
DIST tor-0.3.5.3-alpha.tar.gz 6862572 BLAKE2B c4832828042bbecaf7c34bcb8999873cb4a5314598b2731cba02b2335c09fd8685588c52b15345821288cc94c9ab731c150b5010dee27d2dce1a15914ee31a6d SHA512 fdbbf5a69f9c0708afa4bb9e4925db4f7384997d7f497f1298d0106b76944c060c858fd061aa292310384e7b35f0ac41570cd89bb8c7e8208c832908fa3288af
DIST tor-0.3.5.4-alpha.tar.gz 6867919 BLAKE2B 0b9ecb02c4399df80a641825d955ca39c6d8712e8706db63d9946698adf77cf4af0d947077e6150da60e38a41accf6e6894bd29e54c1fc590a38fbc9003220bc SHA512 8bb6c72295fb6d92301fc59159368960d1b12c3c24cbca8620efe20121192d3307fd0e44d91c5cf69bbc27486ad31ec87db04ff732a7eef36b0b5d81898d3cda
+DIST tor-0.3.5.5-alpha.tar.gz 6893528 BLAKE2B 36d3ac98cd535046110ef24f8e388481ecfac2cd01f52b8fe1f0a88e0639ee5bbf620b50b256c954f1bc37da5c99bc8bf74a29315c3def9f21e4ab845a213153 SHA512 963aeb6ecdf8c772670261a49e273a89b5a5ac4296aec445fecf42996059a1aecaadba198a495c665afab02fc55d2572f0e66a7ebfc775512d029d53c3fd6575
diff --git a/net-vpn/tor/tor-0.3.5.5_alpha.ebuild b/net-vpn/tor/tor-0.3.5.5_alpha.ebuild
new file mode 100644
index 000000000000..c6f1f5f1020a
--- /dev/null
+++ b/net-vpn/tor/tor-0.3.5.5_alpha.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic readme.gentoo-r1 systemd user
+
+MY_PV="$(ver_rs 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="https://www.torproject.org/dist/${MY_PF}.tar.gz
+ https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="caps libressl lzma scrypt seccomp selinux systemd tor-hardening test zstd"
+
+DEPEND="
+ app-text/asciidoc
+ dev-libs/libevent[ssl]
+ sys-libs/zlib
+ caps? ( sys-libs/libcap )
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+ lzma? ( app-arch/xz-utils )
+ scrypt? ( app-crypt/libscrypt )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd )
+ zstd? ( app-arch/zstd )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-tor )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
+ "${FILESDIR}"/${PN}-0.3.3.2-alpha-tor.service.in.patch
+)
+
+DOCS=( README ChangeLog ReleaseNotes doc/HACKING )
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_configure() {
+ export ac_cv_lib_cap_cap_init=$(usex caps)
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ --enable-system-torrc \
+ --enable-asciidoc \
+ --disable-android \
+ --disable-libfuzzer \
+ --disable-module-dirauth \
+ --enable-pic \
+ --disable-rust \
+ --disable-restart-debugging \
+ --disable-zstd-advanced-apis \
+ $(use_enable lzma) \
+ $(use_enable scrypt libscrypt) \
+ $(use_enable seccomp) \
+ $(use_enable systemd) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening) \
+ $(use_enable test unittests) \
+ $(use_enable test coverage) \
+ $(use_enable zstd)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r8 tor
+ systemd_dounit contrib/dist/tor.service
+
+ keepdir /var/lib/tor
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r1 torrc
+}