summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2023-02-04 18:42:58 +0100
committerHanno Böck <hanno@gentoo.org>2023-02-04 18:42:58 +0100
commit27a036af17ab8f4257289448e14847e4880fe645 (patch)
tree355f7a19aee9e228a6469cccb6e8ff2c0505a1b8
parentdev-util/vulkan-tools: Stabilize 1.3.236 ppc64, #893224 (diff)
downloadgentoo-27a036af.tar.gz
gentoo-27a036af.tar.bz2
gentoo-27a036af.zip
mail-filter/zdkimfilter: Add missing libbsd dep.
Signed-off-by: Hanno Böck <hanno@gentoo.org> Closes: https://bugs.gentoo.org/893216
-rw-r--r--mail-filter/zdkimfilter/zdkimfilter-3.13-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/mail-filter/zdkimfilter/zdkimfilter-3.13-r1.ebuild b/mail-filter/zdkimfilter/zdkimfilter-3.13-r1.ebuild
new file mode 100644
index 000000000000..495b98b46cd9
--- /dev/null
+++ b/mail-filter/zdkimfilter/zdkimfilter-3.13-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DESCRIPTION="DKIM filter for Courier-MTA"
+HOMEPAGE="https://www.tana.it/sw/zdkimfilter"
+SRC_URI="https://www.tana.it/sw/zdkimfilter/${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="net-libs/gnutls
+ mail-mta/courier
+ dev-db/opendbx
+ dev-libs/nettle:=
+ net-dns/libidn2:=
+ dev-libs/libunistring:=
+ dev-libs/libbsd"
+RDEPEND="${DEPEND}"
+
+# Tests don't work with portage sandbox
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ diropts -o mail -g mail
+ dodir /etc/courier/filters/keys
+ dodoc release-notes-*.txt README ChangeLog
+ dodoc odbx_example.{conf,sql}
+}