summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2022-11-21 17:04:42 -0500
committerSam James <sam@gentoo.org>2022-11-22 06:17:38 +0000
commit27a734780feb83255e554a43905962d0eec21727 (patch)
treea45fb55e8f3aff5945b32a79c9830cb1c3b170cf
parentgnome-extra/cinnamon-control-center: drop 5.4.7 (diff)
downloadgentoo-27a734780fe.tar.gz
gentoo-27a734780fe.tar.bz2
gentoo-27a734780fe.zip
gnome-extra/nemo: add 5.6.0
Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--gnome-extra/nemo/Manifest1
-rw-r--r--gnome-extra/nemo/nemo-5.6.0.ebuild135
2 files changed, 136 insertions, 0 deletions
diff --git a/gnome-extra/nemo/Manifest b/gnome-extra/nemo/Manifest
index fe165f093841..aab9276d650b 100644
--- a/gnome-extra/nemo/Manifest
+++ b/gnome-extra/nemo/Manifest
@@ -1,2 +1,3 @@
DIST nemo-5.2.4.tar.gz 1492077 BLAKE2B dc6efb24921d5408938ff5b8660653789a77d6607e2e023d73eb5722a0a8bc75cd22d1241f5e852d0429d05f6ec4fd1abb798b8be1ecf513eeed108a256e506c SHA512 0aa3f7e0c2bdb9d7f1874c17caea0e4a3da062fc243de1f1657bdb83090a1afb099baa404f211092f83cf6852c423b244482faf0ad6beaaddc072cbce17cc6d4
DIST nemo-5.4.3.tar.gz 1495378 BLAKE2B 1135f1190e23bb259967352afb1da11bd8aad14b30ed2256fc1e00b932845b8e8129648134e21459a47d7fa7a88cc8c08f3de21760e07ff1f7911c28ed4e784b SHA512 3bb509c6999f145e463a437cd1e45bb32d1aaea10531d22b46c46811a7c196d5a26db77b357c082c03621a0cc545feb10ad218a7af81dfecdffbffa381a047da
+DIST nemo-5.6.0.tar.gz 1496505 BLAKE2B 00fa26ed9215f0047571eabe3d5c4270e759d1ee0be08972f55af14c6bf793d426ed7a171b4b32804b0369a0356070a2063f55772b0a06f6d9944d95583d0249 SHA512 92956e8a42c4a9dcc6021433c7c6f793b9f0eb173e3209a721c0d5a2b17e19da104e06a2b26f1d0f7b4d89a5a9648838f75d4f97c36b3ac33ca2af104c3dee03
diff --git a/gnome-extra/nemo/nemo-5.6.0.ebuild b/gnome-extra/nemo/nemo-5.6.0.ebuild
new file mode 100644
index 000000000000..a1590557ed37
--- /dev/null
+++ b/gnome-extra/nemo/nemo-5.6.0.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10,11} )
+
+inherit meson gnome2-utils python-single-r1 readme.gentoo-r1 virtualx xdg
+
+DESCRIPTION="A file manager for Cinnamon, forked from Nautilus"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/nemo"
+SRC_URI="https://github.com/linuxmint/nemo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="exif gtk-doc +nls selinux test xmp"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# https://github.com/linuxmint/nemo/issues/2501
+RESTRICT="test"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ || (
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/atk
+ )
+ >=dev-libs/glib-2.45.7:2[dbus]
+ >=dev-libs/gobject-introspection-0.9.12:=
+ >=dev-libs/libxml2-2.7.8:2
+ gnome-base/dconf:0=
+ >=gnome-extra/cinnamon-desktop-5.6:0=
+ gnome-extra/libgsf:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.10.0:3[introspection]
+ x11-libs/libX11
+ >=x11-libs/pango-1.40.0
+ >=x11-libs/xapp-2.4.1
+
+ exif? ( >=media-libs/libexif-0.6.20:= )
+ selinux? ( sys-libs/libselinux )
+ xmp? ( >=media-libs/exempi-2.2.0:= )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ x11-themes/adwaita-icon-theme
+
+ nls? ( >=gnome-extra/cinnamon-translations-5.6 )
+"
+PDEPEND="
+ >=gnome-base/gvfs-0.1.2
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ >=dev-util/gdbus-codegen-2.31.0
+ >=dev-util/intltool-0.40.1
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ gtk-doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ # Undo the switch to untex as it's not packaged.
+ "${FILESDIR}/${PN}-5.0.3-use-detex.patch"
+)
+
+DISABLE_AUTOFORMATTING="yes"
+FORCE_PRINT_ELOG="yes"
+DOC_CONTENTS="
+${PN} functionality can be extended by installing other packages.
+
+sys-apps/gnome-disk-utility - Mount archive files
+gnome-extra/nemo-fileroller - Extract/Create archive files
+
+${PN} search capabilities can be extended through external
+helpers. Install any of the following packages to make
+their associated file types searchable.
+
+epub - app-arch/unzip and app-text/html2text
+Image metadata - media-gfx/exif
+MP3 tags - media-sound/id3
+Microsoft Office .doc - app-text/catdoc
+Microsoft Office .xls - dev-python/xlrd
+OpenDocument/LibreOffice - app-text/odt2txt or app-office/unoconv
+PDF - app-text/poppler[utils]
+PostScript - app-text/ghostscript-gpl
+TeX - app-text/texlive-core
+"
+
+src_prepare() {
+ default
+ python_fix_shebang files/usr/share/nemo/actions install-scripts
+}
+
+src_configure() {
+ # tracker: only supports unmaintained tracker-2, not >=tracker-3.
+ local emesonargs=(
+ $(meson_use exif)
+ $(meson_use xmp)
+ $(meson_use selinux)
+ $(meson_use gtk-doc gtk_doc)
+
+ -Dtracker=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}