summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-15 09:29:28 +0000
committerSam James <sam@gentoo.org>2023-02-15 09:29:59 +0000
commit27bd73e1860c85f68ba5353eec6b88bafbe615a2 (patch)
tree50957759c6b34d0f26c22fe304ea0399b446bfb4
parentsys-firmware/intel-microcode: tweak USE flag description style (diff)
downloadgentoo-27bd73e1860c85f68ba5353eec6b88bafbe615a2.tar.gz
gentoo-27bd73e1860c85f68ba5353eec6b88bafbe615a2.tar.bz2
gentoo-27bd73e1860c85f68ba5353eec6b88bafbe615a2.zip
sys-devel/crossdev: add 20230209
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20230209.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 7953946f2dc9..48c346ba8bfb 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1,2 +1,3 @@
DIST crossdev-20220909.tar.xz 29480 BLAKE2B 9c3ef9d9b8f13c81f9d2e21f8914158c04035a105ee1ac90ba30cb23a69744c9c6959bbcfd2e50d29144fc79937e5e585054d2eedfb2ced65a88467e509243be SHA512 86e8900a13095b7b12b00d739d28e2921f98818cd62daccfe6d750ce02113d0ef2d5e470b500bbfb80a9cf8f05b2a13882ac9963c3f1a4e1b7454bc1201df183
DIST crossdev-20221228.tar.xz 29568 BLAKE2B 0458a338a872a27058240c816abfcf9116703d18b687da0050213f834d5aba5df87552e16999fca7d0340aab5b8738ee0edb6ccfb656579b99f20357c077e326 SHA512 16d9d72f74c3b0d6c587c16eb8bea405c7c8eb3effc59fac55027d02348db2e10aacd9098b6f42479574a014783022737325acfaf63031e430fdf90391fa574b
+DIST crossdev-20230209.tar.xz 29608 BLAKE2B 591e854f798c4abf90950a5ab229b14740cd43a77f83f85827487d2339a040eaf107305ef993a24783281f2f655eb377c60d043c071788cc2e798c746d9498b3 SHA512 41e482e6f5614d3ea3bcc3115f9aa86ba6c9302fef67af5b0c0058deba106c60f0b13e8881b7246180ce6d3bfaf77516e45e4f444317dc4eaec074850b79f4b4
diff --git a/sys-devel/crossdev/crossdev-20230209.ebuild b/sys-devel/crossdev/crossdev-20230209.ebuild
new file mode 100644
index 000000000000..4cb66350d4ce
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20230209.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/crossdev.git
+ https://github.com/gentoo/crossdev
+ "
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ app-shells/bash
+ sys-apps/gentoo-functions
+"
+BDEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ ${PV} == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}