summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBlake LaFleur <blackburn2929@gmail.com>2023-12-08 13:11:46 -0600
committerYixun Lan <dlan@gentoo.org>2023-12-13 12:17:57 +0000
commit27c0d0dee8146e9fd61de5e8ed6096fd226674a0 (patch)
treed5e645dce8d3ec656ec4b9d15cdcf3fd3a3e5eab
parentdev-vcs/stgit: fix QA warning (diff)
downloadgentoo-27c0d0dee8146e9fd61de5e8ed6096fd226674a0.tar.gz
gentoo-27c0d0dee8146e9fd61de5e8ed6096fd226674a0.tar.bz2
gentoo-27c0d0dee8146e9fd61de5e8ed6096fd226674a0.zip
dev-cpp/tomlplusplus: new package
Signed-off-by: Blake LaFleur <blackburn2929@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--dev-cpp/tomlplusplus/Manifest1
-rw-r--r--dev-cpp/tomlplusplus/metadata.xml8
-rw-r--r--dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild39
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-cpp/tomlplusplus/Manifest b/dev-cpp/tomlplusplus/Manifest
new file mode 100644
index 000000000000..8fdc90bd67a4
--- /dev/null
+++ b/dev-cpp/tomlplusplus/Manifest
@@ -0,0 +1 @@
+DIST tomlplusplus-3.4.0.gh.tar.gz 1294731 BLAKE2B 9495ccd78707ced11744eab7c1c0bf0c0c28e283d186195bb48d1059bae7eb1a874bc964b0fc45210fd73ffd7485ecf3e1159da227d0e1c8ff249e79c08eecf0 SHA512 c227fc8147c9459b29ad24002aaf6ab2c42fac22ea04c1c52b283a0172581ccd4527b33c1931e0ef0d1db6b6a53f9e9882c6d4231c7f3494cf070d0220741aa5
diff --git a/dev-cpp/tomlplusplus/metadata.xml b/dev-cpp/tomlplusplus/metadata.xml
new file mode 100644
index 000000000000..0dfeb9e00e18
--- /dev/null
+++ b/dev-cpp/tomlplusplus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">marzer/tomlplusplus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild b/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild
new file mode 100644
index 000000000000..c239fca55478
--- /dev/null
+++ b/dev-cpp/tomlplusplus/tomlplusplus-3.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="TOML config file parser and serializer"
+HOMEPAGE="
+https://marzer.github.io/tomlplusplus/
+https://github.com/marzer/tomlplusplus
+"
+SRC_URI="https://github.com/marzer/tomlplusplus/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild_lib=true
+ -Dgenerate_cmake_config=true
+ -Duse_vendored_libs=true # for test dependencies, header only and very restrictive version requirements
+ $(meson_use test build_tests)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ local emesontestargs=(
+ 'tests - C'
+ )
+
+ meson_src_test "${emesontestargs[@]}"
+}