summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-03-07 14:05:39 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2024-03-07 14:09:49 -0600
commit27cd6133bd4c9c2e2dc777fed247c4e186c22673 (patch)
tree191e6e5afe51cd27207b72e933ba81c2bd0501b4
parentapp-admin/puppet: add 8.5.1 (diff)
downloadgentoo-27cd6133.tar.gz
gentoo-27cd6133.tar.bz2
gentoo-27cd6133.zip
app-admin/puppet-agent: add 8.5.1
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-8.5.1.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 7893bb38e31c..1108445271a9 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -6,3 +6,5 @@ DIST puppet-agent_8.4.0-1focal_amd64.deb 35930626 BLAKE2B ad299aaceba51bd2831c6a
DIST puppet-agent_8.4.0-1focal_arm64.deb 35421066 BLAKE2B 348f4cb16b83e0703fe8ec1fc6a5ebd992384c02f51b8d38d597d629b19f070f21e0f944ba1c6188bd9d93d0689e66ef10a4c717847ffca2534b4c6a3fa0eb4d SHA512 5ba2d6d41e6d98e0e7830fc6140500173e1e18efd9c228c84ec124c5154df847657f4c43f994d05830774fc6431b49d57081ded579ed1215927623c7b83155a7
DIST puppet-agent_8.5.0-1focal_amd64.deb 35945720 BLAKE2B 485fa3e93006c63265df27ba99e61e1c9b253f71976aa92af1bc0ee474b575c27d3e1d3ddde21a919f5a21e151777b1ab8f7d849f5927a48898ca58b14edaa8b SHA512 a252240e206fb93bfc882f88e593a93b29c61442bb7fc95e1d3465e30af6b7bd82a362287590a36460ed04d4759fc244d3eff118ef8790885112ef78206a14f9
DIST puppet-agent_8.5.0-1focal_arm64.deb 35436786 BLAKE2B 712f893f05f9f75bf7af0cf40556f0746a81fabbd8e588ad598f59856bfe4948c53eb92e2eaa7a621507183c572d17ecb2b426b13a91bbd0b98cc2463070a60e SHA512 ce1752d13b2d4b9442ef11006e8bc0edf98e855df051491efd2760b6919c41f0dda2030910e5794658ae99d3b8341e9bf64aa57c65069f9d83a3f328f1d2dd41
+DIST puppet-agent_8.5.1-1focal_amd64.deb 35945834 BLAKE2B 8c839eabf8abbc6cf87ab8a1c942b97be7fc08b9053695d07a7fc4bbf69886192063553c43f81e73521327cf8b89af18fe43d41ef3f71229d218fe123426f50c SHA512 324ea532d005a1bbb0f25fdd411f3f68a1c18371cb494f8934d73d87c19e3bbf46c653a9afbe767ed2ab6e788115f31ccef4bd084351ee6f73e4e656aab5d65a
+DIST puppet-agent_8.5.1-1focal_arm64.deb 35436770 BLAKE2B 16ead6317dab6f8b65b8ea5269eec5593697f4da6d1ec0323e074f4eab3c8518dab10af48853e591aecc62c63a5ff4e135cf02bb1d7f7d565c5200bfae98ff86 SHA512 f3acc097563d9a56cb677df72250ee25ab0e1e361eb40a2cd36b3d694854edc3850f08099b916aefbc16580f78a194e9f3bf33b1cb585836d55c6e8dcf03a379
diff --git a/app-admin/puppet-agent/puppet-agent-8.5.1.ebuild b/app-admin/puppet-agent/puppet-agent-8.5.1.ebuild
new file mode 100644
index 000000000000..f5524d744e1b
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-8.5.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd unpacker tmpfiles
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="amd64? ( http://apt.puppetlabs.com/pool/focal/puppet8/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb )
+arm64? ( http://apt.puppetlabs.com/pool/focal/puppet8/${PN:0:1}/${PN}/${PN}_${PV}-1focal_arm64.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+# virtual/libcrypt:= is in here despite being a pre-built package
+# to ensure that the has_version logic for the symlink doesn't become stale
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet
+ virtual/libcrypt:="
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt[compat]
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ keepdir var/log/puppetlabs/puppet/
+ chmod 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd2" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+
+ # Handling of the path to the crypt library during the ongoing migration
+ # from glibc[crypt] to libxcrypt
+ # https://www.gentoo.org/support/news-items/2021-07-23-libxcrypt-migration.html
+ if has_version "sys-libs/glibc[crypt]"; then
+ local crypt_target='../../../../usr/lib64/xcrypt/libcrypt.so.1'
+ else
+ local crypt_target='../../../../usr/lib/libcrypt.so.1'
+ fi
+ dosym $crypt_target /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet-agent.conf
+}