summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-29 09:12:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-29 11:16:19 +0200
commit27d1d3c06a7c429b667e9d03dd3b46377af0eee7 (patch)
tree8d2656fdc432e317f5da003684b9e5bfd9b20a59
parentdev-python/cycler: Bump to 0.11.0 (diff)
downloadgentoo-27d1d3c0.tar.gz
gentoo-27d1d3c0.tar.bz2
gentoo-27d1d3c0.zip
dev-util/stripe-mock: Bump to 0.113.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.113.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index b16959d4aa99..c099d2c1a640 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1,3 +1,4 @@
DIST stripe-mock-0.110.0.tar.gz 604856 BLAKE2B ce8b83ce4787d56752ce47f919c049a32ad0addf67db0461a70fba2380406e5dbaf0e096011a3a371d897d9bd3ef6c573cdec1b66607b0d4b99c3fc11a931d19 SHA512 8501a8d41d0dbba77064abbf083162393453b884bcc9077793d7a75948a925fb056ff37ef74d5d789598d9081639f74016f06980954d3be84a9131ceb21539b2
DIST stripe-mock-0.111.0.tar.gz 604494 BLAKE2B c9aad7c4b939a49c6a947cc3a2b2506b0c2b7e2c0e1f8841f92b7d53e1138a4e6333eaecf6f2a984861df6fb67800acd8d29b3774b8970e5e482f58fed4e9c53 SHA512 1b01136bb52543052bd66b1c7112181dc0834d5e17ff0590fd2dfad8fdc593eb21967e7ecc3ecac8ae7882e44410e752ddd203b9a87b34d6f4c1fea1cd3ebbb2
DIST stripe-mock-0.112.0.tar.gz 627738 BLAKE2B 7ce44762596de04edda1e544a6bc77c36f68dabbebb280881d9e992b3f08054c9a3dc6805fc6060cabed5c9fcf185ccdf89835c123c9145cd2dccbd57fdf4461 SHA512 8d78712e99c95ab07514406f850d4255ff69bcca804b030a23ec9cb6a19408ade26836a2b4be6262868bc57ad68542112816edf3c6508c01a9bcbc4202922a27
+DIST stripe-mock-0.113.0.tar.gz 628049 BLAKE2B 5886bc5884bac74502014e1ad59bcc16f1c58f373142c9aca9129b7c8c70556bcfda23576f2c70d71fd9a99bed00f0f95a36e26e95cef58aebf9a37a21e42bbd SHA512 1a3687685a5c48de89946a4949ee4da367585b5adecf6e9d002493f8ab23b1eb8e38e87ec0b60d6157ddcbd8601ef5c1fef5d279a98e80eb34e0bd529f798185
diff --git a/dev-util/stripe-mock/stripe-mock-0.113.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.113.0.ebuild
new file mode 100644
index 000000000000..05a7220e34b0
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.113.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_SRC="github.com/stripe/stripe-mock"
+EGO_PN=${EGO_SRC}/...
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/stripe-mock
+ rm -rf "${D}$(get_golibdir_gopath)" || die
+}