summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-31 09:43:21 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-31 11:20:58 +0200
commit27e5c060112d676eac32b166bf44f3efdac5a6fc (patch)
treed0241e809af1aba1ab033d517bbd487e04c9d646
parentdev-python/boto3: Bump to 1.24.63 (diff)
downloadgentoo-27e5c060.tar.gz
gentoo-27e5c060.tar.bz2
gentoo-27e5c060.zip
app-admin/awscli: Bump to 1.25.64
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.64.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 2338ded467b4..a3a78f14d597 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -15,3 +15,4 @@ DIST aws-cli-1.25.58.gh.tar.gz 2256521 BLAKE2B 752581d8e6cf82fa5a77f8b530d1d267f
DIST aws-cli-1.25.59.gh.tar.gz 2256634 BLAKE2B 0fd3dbd2b3f59ee32d3e9d11c529184be54192057e273ed79a1d0e4871673f1318d3ef779d13067e162d334119f7c859c8b175a513095e7252bcf6bfb1a15675 SHA512 1f59362da22f542ec8af3e91343857f37922bca25f7e554bce66926e58a29fc63bfcd7308e8784e5bb69f8f8e032fe501502b6ab60798224b090f79d7170c17e
DIST aws-cli-1.25.60.gh.tar.gz 2257567 BLAKE2B 368925e5dfd5b9fa3ab6c7a34c1f8e8312946df790534874a67aa248e81fc2defc5825e35a871d326e00acec31d5ec6a9c87fe1eff5925d489a8a87df7c059c5 SHA512 559c5cdb3cc1c0c94d77d97b7a7e4d2764a301c7ceaf0a557769629aed1ee9db0952669a265e0a54b828e5de39e320b9e4ad0b591868cfe17f8033a8eb8c4a9e
DIST aws-cli-1.25.61.gh.tar.gz 2257977 BLAKE2B d1090ca3eb86284520e970a997932af31c250d2ca12ab7ddd2a64a55540e5b747bd30d21f4b0fdb8cd926692bde53a37b618f4cc2b9e92c7fcbca95419d7fb36 SHA512 cb869e08b9bec7c542d44401590f3ee5500564c23ff17d47e6a0265e1f98aea7429e55757e2184d7fbf23b3bb65366692040c059cdfffef39e1de2072345060c
+DIST aws-cli-1.25.64.gh.tar.gz 2263441 BLAKE2B d68ef0a3dabba879d9d650a911d5f286116a6d407d9d958088f7b7cd54c27db3be28165a1676e949785056519477f315ca4e08f6df9938da2516974d026fef81 SHA512 4db256228dde6aed2432133373c045bf2f2e69a7764629f3d13a94e086f99b43cc2a29862e6f973742a0de08032e6c26499b230db81575eabd288c8f2f63eb0a
diff --git a/app-admin/awscli/awscli-1.25.64.ebuild b/app-admin/awscli/awscli-1.25.64.ebuild
new file mode 100644
index 000000000000..3d5bba5c1200
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.64.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# botocore is x.(y+2).(z-1)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 1 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}