summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-06 11:41:16 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-06 11:45:19 +0200
commit27f9e8f75cdd028f622343658bb908d5979fee81 (patch)
treece8da6959fd844b0e65f734d9e0bc8c0e710cd63
parentprofiles/arch/arm64: stable-mask octave[sundials] (diff)
downloadgentoo-27f9e8f7.tar.gz
gentoo-27f9e8f7.tar.bz2
gentoo-27f9e8f7.zip
app-emacs/helm: bump to 3.8.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/helm/Manifest1
-rw-r--r--app-emacs/helm/helm-3.8.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
index 68afc72c395e..981c9b88d04e 100644
--- a/app-emacs/helm/Manifest
+++ b/app-emacs/helm/Manifest
@@ -1,2 +1,3 @@
DIST helm-3.8.4.tar.gz 2346120 BLAKE2B 2f554a6a3fc3a42ba2761c267d085ad1e6679f4913bc19cdbbff11130922d93d2fbe75bcae8230748c39148b6e42d45d4c2c711f731ebd4a1984c5927d93d290 SHA512 011cc4eb79a0a6916404428b9f645e4401b8a0b8b473bec88ac4211d4157b78cc673922c1b74dc93d60cf036135a67bd9c174198b63edd63a6d26a40ba9c1b9d
DIST helm-3.8.5.tar.gz 2349290 BLAKE2B 84f0c15c2a9f492246defdf9496e8dcc5265b0c60b50ccaaa3b9f6731285a667da919da7fec80d77a4fd11bc83d9f4ae4c0910e31423b58afbdf00d51b070295 SHA512 af727553c29c9fa0ba6eb6a73b25d62855ea4413eebc57baf3ed94be6a0240e4c558193c898430dc21132ba5e32ead584514910bf98b3b8d82adf7828f953652
+DIST helm-3.8.6.tar.gz 2356253 BLAKE2B 62b9af26888526f54726468e04677c401c5e828e588cb6f2c005b9ce9d84935c184b536a97a82e4e6c08c3523a10a32f9348d243d2545c17c9480ad004d92d10 SHA512 71342f347aa5cf8bd3e1990c8633d908e6a5fe66e051554aa2f554fba5d63b2623fe2b6b07540473b481986b1d5d27cb2d8b06f127e727aa8d373bc045d0a602
diff --git a/app-emacs/helm/helm-3.8.6.ebuild b/app-emacs/helm/helm-3.8.6.ebuild
new file mode 100644
index 000000000000..68aff2bea3b6
--- /dev/null
+++ b/app-emacs/helm/helm-3.8.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="app-emacs/async
+ app-emacs/popup"
+BDEPEND="${RDEPEND}"
+
+PATCHES="${FILESDIR}/${PN}-3.8.0-no-autoload-check.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+ dobin emacs-helm.sh
+}