summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:26:38 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:26:38 +0100
commit280c56180bcf90b2b924dc30a04fa375c83e4e64 (patch)
treed9b2d894fd1a173e7429c24f2e30fa1a955ffe90
parentdev-python/nbconvert: Import from science overlay (diff)
downloadgentoo-280c5618.tar.gz
gentoo-280c5618.tar.bz2
gentoo-280c5618.zip
dev-python/jupyter_console: Import from science overlay
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-python/jupyter_console/Manifest1
-rw-r--r--dev-python/jupyter_console/jupyter_console-4.0.3.ebuild55
-rw-r--r--dev-python/jupyter_console/metadata.xml13
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/jupyter_console/Manifest b/dev-python/jupyter_console/Manifest
new file mode 100644
index 000000000000..bb6efd81b3df
--- /dev/null
+++ b/dev-python/jupyter_console/Manifest
@@ -0,0 +1 @@
+DIST jupyter_console-4.0.3.tar.gz 22090 SHA256 555be6963a8f6431fbe1d424c7ffefee90824758058e4c9a2ab3aa045948eb85 SHA512 da9c311d881bbf61fbcea3c79e4dbdbe00f0f713772d0da4d30e0dec36ff5a6c5cbff3b996770f532c1e9c61ade1b1bf7a6f1ed28188ffd6900f6cc2ce7c0665 WHIRLPOOL 37139a87b182b9100284766ffb6e0b4c4e44b9bc2261a2d466920b0a23cf62d55f6a68cfb77da67a2eb3c316582fa7afaddcce69074b7597122e1c858c9a6c26
diff --git a/dev-python/jupyter_console/jupyter_console-4.0.3.ebuild b/dev-python/jupyter_console/jupyter_console-4.0.3.ebuild
new file mode 100644
index 000000000000..0086a624dcdc
--- /dev/null
+++ b/dev-python/jupyter_console/jupyter_console-4.0.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests --with-coverage --cover-package=jupyter_console jupyter_console || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jupyter_console/metadata.xml b/dev-python/jupyter_console/metadata.xml
new file mode 100644
index 000000000000..a069311d1416
--- /dev/null
+++ b/dev-python/jupyter_console/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ A terminal-based console frontend for Jupyter kernels.
+ This code is based on the single-process IPython terminal.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">jupyter_console</remote-id>
+ <remote-id type="github">jupyter/jupyter_console</remote-id>
+ </upstream>
+</pkgmetadata>