summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-14 22:04:36 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-14 22:32:02 -0500
commit28131e8594fd0959580baf6b81691423f5bc21e4 (patch)
treeb2f5bbe207e857ab26ff1aa6973eb84377e079c1
parentdev-python/yarl: version bump to 0.14.1 (diff)
downloadgentoo-28131e85.tar.gz
gentoo-28131e85.tar.bz2
gentoo-28131e85.zip
dev-python/aiohttp: version bump to 2.3.2
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-2.3.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index c7b6065e7d17..6a0e37cc1cd8 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -10,3 +10,4 @@ DIST aiohttp-1.3.3.tar.gz 526273 SHA256 103433f594442b98ed4af9db02331e548a0ef2d4
DIST aiohttp-1.3.5.tar.gz 527432 SHA256 cd14a45da385b5e860849ffaff3ecee56f9b37bf9e7f3f7bc5ce3f17556cf842 SHA512 b99630fa9006163d61e0e010972aee8daad021c5ad0152b04fb6f8b661f18ea03fcfa8d35603ecfcdaef4ecbaff0159b49e2f40164241bb5def48b2847e2d966 WHIRLPOOL b39e5a5081cadb497aa982b8bee1a24615a2e382071755586c52855529c7984c9140c04239fe9ef81e51f3e11a1ea7b1c021f6b8a4dd58c4d826f934394b5576
DIST aiohttp-2.1.0.tar.gz 748642 SHA256 3e80d944e9295b1360e422d89746b99e23a99118420f826f990a632d284e21df SHA512 bd8eea366d380b88ba2c88d2aab722cd0970d2239dd0057cf4596f472a1b1bf38aebbd6cc707379ad9b5f901f93a56c1c4dd32584cb2636af0e013aa11388e25 WHIRLPOOL 45cf17ea7db2eb385d922cd4cdf5aac40244939066a6632f453fa2545fe1a73dfe0d0c43c3dcd60936a403174a69a8fd027dae2e55fc901594d388bd4b5c4cc3
DIST aiohttp-2.2.0.tar.gz 781951 SHA256 1558ba6896c2ed4e1b3cbdc4ba479b4a03a0c1433af2fe23704d2959a0c5191e SHA512 547f7484651aa5df43174cede2537c120ebf10b913ab506cdcbbe8d8702492a9e3374cf772c5d11969ca7a7e3d2602d794e98878ed43d05ae4a8324613138ea4 WHIRLPOOL 5c97f0ccbc2015e6fb7ac31ff0539d123c445673b4444d7ab3b5098c94496b42b8880b8612e6bf3ee0604309aed4ec5d80c3020ed940cd28df0adac5cff28720
+DIST aiohttp-2.3.2.tar.gz 841030 SHA256 42373fbdbe8f09233c17e74f53cee877bc7d5b495b4fc14c32a119255e85e736 SHA512 e481787fec8c9f21d49978b378fb5ef8c06d06cd7a6625fc36c5d4a035e9047f4ed0e38b25b613f1b685ca40e18c796376750f4ac0970fcd1d72ca7fbe31d13f WHIRLPOOL 58da919519c67c084528a059ab3c0d8b577ac0eaaa50a8783842d390a5bb274eba14f11a8d86ded7cc64be2e068e05b6513a4249b000926cd0e3fcc040000f0a
diff --git a/dev-python/aiohttp/aiohttp-2.3.2.ebuild b/dev-python/aiohttp/aiohttp-2.3.2.ebuild
new file mode 100644
index 000000000000..669641f6390c
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-2.3.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/aiohttp"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/async_timeout-1.2.0[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/multidict-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-0.11[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+DOCS=( CHANGES.rst CONTRIBUTING.rst CONTRIBUTORS.txt HISTORY.rst README.rst )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${PWD}:${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}