summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-31 08:05:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-31 09:13:11 +0200
commit282c1ed300b8bf257429651f2aeff7050cc2a4ae (patch)
tree106f4552940914c00b41a04d501bfe475733f6ac
parentdev-python/pyupgrade: Bump to 3.10.1 (diff)
downloadgentoo-282c1ed3.tar.gz
gentoo-282c1ed3.tar.bz2
gentoo-282c1ed3.zip
dev-python/simpy: Bump to 4.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/simpy/Manifest1
-rw-r--r--dev-python/simpy/metadata.xml2
-rw-r--r--dev-python/simpy/simpy-4.0.2.ebuild37
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/simpy/Manifest b/dev-python/simpy/Manifest
index 63995277851e..981af1ba8e1c 100644
--- a/dev-python/simpy/Manifest
+++ b/dev-python/simpy/Manifest
@@ -1 +1,2 @@
DIST simpy-4.0.1.tar.gz 410082 BLAKE2B 09c6f29d2792ac15bb4a3b42a1cdbd4d342aca0ef528aadbe37e01342534645939c9663977230ec7f6f1542a4354925e25f0c5b3bf6e20b29b6da2e69f3d5a90 SHA512 5cc4baada79503e3c2f2425b9f7f00d68f263283ff0cae048fba86665c4dcf70590683f6b7df50d1c1a914ac7cb471ed4b6850676030bea4a3a70fb40eb2cdb4
+DIST simpy-4.0.2.tar.gz 410706 BLAKE2B 787da43fe29135ef3f70f286074e5b6dba50c26f50910674a290a4e9e95fe68dffca5e5308e629f8359181f9e7200938b980bdbd9d7b2c09beb30dd49069fdce SHA512 a1f9e10928930817a07ee851f3190c4aefb9c4f0538557b7cc5b0f8950ed2234878f29d1790cbf6991b78bbd73e989d7df0ed1997847eedf129fc9d1c4d1fc23
diff --git a/dev-python/simpy/metadata.xml b/dev-python/simpy/metadata.xml
index c4ff96460cc7..d58672bc0f31 100644
--- a/dev-python/simpy/metadata.xml
+++ b/dev-python/simpy/metadata.xml
@@ -6,7 +6,7 @@
<name>Gentoo Science Project</name>
</maintainer>
<upstream>
+ <remote-id type="gitlab">team-simpy/simpy</remote-id>
<remote-id type="pypi">simpy</remote-id>
- <remote-id type="sourceforge">simpy</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/simpy/simpy-4.0.2.ebuild b/dev-python/simpy/simpy-4.0.2.ebuild
new file mode 100644
index 000000000000..e7d76b0c98c1
--- /dev/null
+++ b/dev-python/simpy/simpy-4.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Object-oriented, process-based discrete-event simulation language"
+HOMEPAGE="
+ https://simpy.readthedocs.io/
+ https://gitlab.com/team-simpy/simpy/
+ https://pypi.org/project/simpy/
+"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+# Could not import extension sphinx.builders.epub3 (exception: cannot import
+# name 'StandaloneHTMLBuilder' from partially initialized module
+# 'sphinx.builders.html' (most likely due to a circular import)
+# (/usr/lib/python3.10/site-packages/sphinx/builders/html/__init__.py))
+#distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}