summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-06-01 16:30:01 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-06-01 16:30:47 +0100
commit28432b98983038c5db5b3713c03e5e5fadb4767e (patch)
treeb582be4ff11b17de05d41f6c43e6da933adeec1f
parentprofiles: Mask games-action/guacamelee in non-glibc/multilib profiles (diff)
downloadgentoo-28432b98.tar.gz
gentoo-28432b98.tar.bz2
gentoo-28432b98.zip
games-action/guacamelee: New package
This is for the Gold Edition, which is the only version ported to Linux, from Humble Indie Bundle 11 as that's the only version I have. If you bought it from GOG then please contact me. Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--games-action/guacamelee/Manifest1
-rw-r--r--games-action/guacamelee/guacamelee-20140222.ebuild57
-rw-r--r--games-action/guacamelee/metadata.xml8
3 files changed, 66 insertions, 0 deletions
diff --git a/games-action/guacamelee/Manifest b/games-action/guacamelee/Manifest
new file mode 100644
index 000000000000..66c038e1a974
--- /dev/null
+++ b/games-action/guacamelee/Manifest
@@ -0,0 +1 @@
+DIST Guacamelee_linux_1393037377.sh 552784497 BLAKE2B 1f36e1a6b65bcf774d0f4e15b37d8eda3ec91691c7e3c556f73e903559c3215f3611fdbec284259fe7690037cf4ab8e338c1caa7faea80c8ce98d02581b0de4b SHA512 e52c4099e15f20df6512c3c9617cbf29f5ea428c117a0520ce57bacf99b7d33ace6a04c811fd9ced63b7ba11a3a79549b93f83fd18e42ca9a1366aeb4114cd87
diff --git a/games-action/guacamelee/guacamelee-20140222.ebuild b/games-action/guacamelee/guacamelee-20140222.ebuild
new file mode 100644
index 000000000000..4774a553e4eb
--- /dev/null
+++ b/games-action/guacamelee/guacamelee-20140222.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop unpacker xdg-utils
+
+DESCRIPTION="A Metroidvania-style action-platformer set in a magical Mexican-inspired world"
+HOMEPAGE="http://guacamelee.com"
+SRC_URI="Guacamelee_linux_1393037377.sh"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ media-libs/libsdl2[abi_x86_32,joystick,opengl,sound,threads,video]
+ virtual/opengl[abi_x86_32]
+"
+
+S="${WORKDIR}/data"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "This package requires the Guacamelee! Gold Edition file included in"
+ einfo "Humble Indie Bundle 11. If you have it then please move"
+ einfo "${SRC_URI} to your distfiles directory. If you"
+ einfo "missed it then the game is also available to buy from GOG but the"
+ einfo "package will need adapting first. Please contact the Gentoo Games team"
+ einfo "if you bought it from GOG."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe x86/game-bin ${PN}
+ dosym "${DIR}"/${PN} /usr/bin/${PN}
+
+ insinto "${DIR}"
+ doins -r noarch/{*.dat*,media/}
+
+ exeinto "${DIR}/lib32"
+ doexe x86/lib32/libfmod*.so
+
+ dodoc noarch/README.linux
+
+ newicon -s 512 noarch/Guacamelee.png ${PN}.png
+ make_desktop_entry ${PN} "Guacamelee"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-action/guacamelee/metadata.xml b/games-action/guacamelee/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-action/guacamelee/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>