summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2023-11-09 21:26:36 +0200
committerJimi Huotari <chiitoo@gentoo.org>2023-11-09 23:45:33 +0200
commit284484db744bcf9b3d5380809b82f8ba9d6542eb (patch)
tree65a2a73692dabcd6665852fe246b8f369f363394
parentlxqt-base/lxqt-openssh-askpass: add 1.4.0 (diff)
downloadgentoo-284484db744bcf9b3d5380809b82f8ba9d6542eb.tar.gz
gentoo-284484db744bcf9b3d5380809b82f8ba9d6542eb.tar.bz2
gentoo-284484db744bcf9b3d5380809b82f8ba9d6542eb.zip
lxqt-base/lxqt-notificationd: add 1.4.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest1
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-1.4.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index 20fa7ab2a437..0b9e7d9ef4e9 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1 +1,2 @@
DIST lxqt-notificationd-1.3.0.tar.xz 61064 BLAKE2B 249a2cd764cb8ca0bbd4de1bb903df87b58d1efe6cab775edc60dfd4ac6da7bac4f83fad95d3567df7fd4adb3a0a06372fbd70b44a71a4e40b03dfdd3a062710 SHA512 8bc57c8a6710aaa5d050802a588530ec446611362eaa7c87aae2dae74b7ed9745486a90efbd854dedf79bc9994e13b5444f8b5259452614e01a8b393dd796607
+DIST lxqt-notificationd-1.4.0.tar.xz 61792 BLAKE2B e44c9e80c9fb964547902d242ea0cb5967977e4e9dad1c047daae8dadd105f97fd1cd30c5022511d9ece3c3f1e6fbf74ef79e2a5df2e2725603d3d1151dfb166 SHA512 5ae28b0f49e1e01c8d0fe96f23b961ca962dab33f16025af172777f385d0fd3471c64a7acb78b46e7dc0c370d324a17f10ec9a4c4b3afbde95d47164a5246d0a
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.4.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.4.0.ebuild
new file mode 100644
index 000000000000..4f65c2d4b0d3
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.13.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.11.0
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"