summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-17 10:51:39 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-28 15:15:04 +0200
commit285426ee4a05c7a3c2a5159bdb73f76c3f6fbec1 (patch)
treee6998e32d71b40cc8ae44e5f1744280fbb2a83fd
parentdev-python/envoy: EAPI 6 bump. (diff)
downloadgentoo-285426ee.tar.gz
gentoo-285426ee.tar.bz2
gentoo-285426ee.zip
media-libs/mesa: Split LLVM RDEP into sep block
Split the LLVM RDEPEND into a separate block for improved readability when I start hacking on it.
-rw-r--r--media-libs/mesa/mesa-9999.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 4a8ab358f93a..d9a7ac09fccf 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -97,7 +97,6 @@ RDEPEND="
llvm? (
video_cards_radeonsi? (
virtual/libelf:0=[${MULTILIB_USEDEP}]
- vulkan? ( >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}] )
)
video_cards_r600? (
virtual/libelf:0=[${MULTILIB_USEDEP}]
@@ -105,7 +104,6 @@ RDEPEND="
video_cards_radeon? (
virtual/libelf:0=[${MULTILIB_USEDEP}]
)
- >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
)
opencl? (
app-eselect/eselect-opencl
@@ -139,6 +137,18 @@ RDEPEND="${RDEPEND}
video_cards_radeonsi? ( ${LIBDRM_DEPSTRING}[video_cards_amdgpu] )
"
+# Please keep the LLVM dependency block separate. Since LLVM is slotted,
+# we need to *really* make sure we're not pulling one than more slot
+# simultaneously.
+RDEPEND="${RDEPEND}
+ llvm? (
+ video_cards_radeonsi? (
+ vulkan? ( >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}] )
+ )
+ >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
+ )
+"
+
# FIXME: kill the sys-devel/llvm[video_cards_radeon] compat once
# LLVM < 3.9 is out of the game
DEPEND="${RDEPEND}