summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-13 04:35:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-13 04:35:57 +0200
commit286c4b5dd9ebb65260038d154e005e7bceb66573 (patch)
tree7fb622eb3fc720fb14ca930ec59af55ccbf5a5ce
parentdev-python/jq: Bump to 1.6.0 (diff)
downloadgentoo-286c4b5dd9ebb65260038d154e005e7bceb66573.tar.gz
gentoo-286c4b5dd9ebb65260038d154e005e7bceb66573.tar.bz2
gentoo-286c4b5dd9ebb65260038d154e005e7bceb66573.zip
dev-python/awxkit: Bump to 23.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/awxkit/Manifest1
-rw-r--r--dev-python/awxkit/awxkit-23.1.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/awxkit/Manifest b/dev-python/awxkit/Manifest
index fe162de4df08..7df7a235a90f 100644
--- a/dev-python/awxkit/Manifest
+++ b/dev-python/awxkit/Manifest
@@ -2,3 +2,4 @@ DIST awx-22.5.0.gh.tar.gz 17629249 BLAKE2B 28e560b36fc16173e8b1e0e2dfbab7a30082e
DIST awx-22.6.0.gh.tar.gz 17639868 BLAKE2B 8733d1d81c099a56873bea0f38cafe696c70ae4f9274bee644b82b414317cdc537e22a1beea74d566e07cef4e5f5d3adea66a715f43dc30faab35cea1ee4616f SHA512 05fbe7dcc84902eadb40d8a55cc4022aaeedd015534a4caa379cd68684f96422674677c724e8473b0133f9986ae46a7a4a06649a60c8701bd202bc7d684ec972
DIST awx-22.7.0.gh.tar.gz 17645480 BLAKE2B 06d4da9090db221ab23e86c8a8fc3e548437dc7903b4c05e09fbbbd3fc5254c528f3da0c41895533cb0615c863a1a940d3d254f52142e321243aa3113ce65187 SHA512 811976debbef72d0dce16caae1f6d19acafde5b7c15bfba9fdef3c5cfa0a2a06c30fbce81b52f0f1f63466d0cd8e6021e62819f5d134a59333d2331df42983eb
DIST awx-23.0.0.gh.tar.gz 17657491 BLAKE2B 0dbd00f45f4c5dfb0f1d74c81a726401375b9eb389622b54a72567e2863dfc76b329b19853802096cd7a7cbc75170003da405e13d26db4ed1b3e8b025cc36dc5 SHA512 bdd5d7644e6b1d01d52c02c26084f0f3c66b2423969d4277bade4b13dbdb614a6a62c408160a95848ecfdbace75e02635c8667ab2033a1f6b36fdf41dbee90c9
+DIST awx-23.1.0.gh.tar.gz 70704479 BLAKE2B dc0e920b2036e71825afda5b65aa6e2326364589d82464d48ccc17e886fd9dfa1eebee005439cb6e628a50be65959208e3e9b02716881833b343e556fd90d8ca SHA512 85e4e8298789f6886b6e63eba90b0af30fe7c78804fe5df187c79af928c05637f4cdac6b69db511e5a37480488bc542b913fd73f2a5cbd0490b1b941fbd4dced
diff --git a/dev-python/awxkit/awxkit-23.1.0.ebuild b/dev-python/awxkit/awxkit-23.1.0.ebuild
new file mode 100644
index 000000000000..52670ed68dde
--- /dev/null
+++ b/dev-python/awxkit/awxkit-23.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1
+
+MY_P=awx-${PV}
+DESCRIPTION="Command line interface for Ansible AWX"
+HOMEPAGE="
+ https://github.com/ansible/awx/
+ https://pypi.org/project/awxkit/
+"
+# no sdist, as of 22.0.0
+SRC_URI="
+ https://github.com/ansible/awx/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/awxkit"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+ printf '%s\n' "${PV}" > VERSION || die
+
+ sed -e 's|websocket-client==[[:digit:]\.]*|websocket-client|' \
+ -e "/'clean'/d" \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}