summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-20 18:49:57 +0000
committerSam James <sam@gentoo.org>2022-03-20 18:51:10 +0000
commit288b7fd3ad17a357dfeeaf9ab7d6e99e82f9ebce (patch)
tree842805bde25e5df9a55efe69591234a5b321854c
parentsci-chemistry/mustang: [QA] fix tc-get* quoting (diff)
downloadgentoo-288b7fd3ad17a357dfeeaf9ab7d6e99e82f9ebce.tar.gz
gentoo-288b7fd3ad17a357dfeeaf9ab7d6e99e82f9ebce.tar.bz2
gentoo-288b7fd3ad17a357dfeeaf9ab7d6e99e82f9ebce.zip
sci-chemistry/procheck: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-chemistry/procheck/procheck-3.5.4-r3.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-chemistry/procheck/procheck-3.5.4-r3.ebuild b/sci-chemistry/procheck/procheck-3.5.4-r3.ebuild
index 1a700ee4110f..d7522b14f7c4 100644
--- a/sci-chemistry/procheck/procheck-3.5.4-r3.ebuild
+++ b/sci-chemistry/procheck/procheck-3.5.4-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -40,8 +40,8 @@ PATCHES=(
src_compile() {
emake \
- F77=$(tc-getFC) \
- CC=$(tc-getCC) \
+ F77="$(tc-getFC)" \
+ CC="$(tc-getCC)" \
COPTS="${CFLAGS}" \
FOPTS="${FFLAGS} -std=legacy"
}