summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-07-29 20:29:09 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-07-29 22:00:21 +0100
commit288e434138c3cd33b61dd5abf57eac7ff3120983 (patch)
treec0717171e4e45ea280d16f35c3a8edc0140bf66b
parentmedia-libs/raspberrypi-userland-bin: drop inherit vcs-snapshot (diff)
downloadgentoo-288e434138c3cd33b61dd5abf57eac7ff3120983.tar.gz
gentoo-288e434138c3cd33b61dd5abf57eac7ff3120983.tar.bz2
gentoo-288e434138c3cd33b61dd5abf57eac7ff3120983.zip
media-libs/raspberrypi-userland-bin: drop inherit multilib
Apparenly multilib.eclass was used only for get_libdir function, and the usage was wrong, because it was appended to the package-specific "/opt/vc/" path which does not need to match system library directory name. More than that, the path "/opt/vc/lib" is actually hardcoded in env.d file installed by this package, so even if get_libdir ever returned something different than "lib", that would break dynamic linkage of the installed executables. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
-rw-r--r--media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild4
1 files changed, 1 insertions, 3 deletions
diff --git a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild
index 88cc1e305527..67de53f9fa04 100644
--- a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild
+++ b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20190709.ebuild
@@ -3,8 +3,6 @@
EAPI=5
-inherit multilib
-
DESCRIPTION="Raspberry Pi userspace tools and libraries"
HOMEPAGE="https://github.com/raspberrypi/firmware"
MY_P="raspberrypi-firmware-${PV}"
@@ -30,7 +28,7 @@ src_install() {
into /opt
dobin bin/*
insopts -m 0755
- insinto "/opt/vc/$(get_libdir)"
+ insinto "/opt/vc/lib"
doins -r lib/*
doenvd "${FILESDIR}"/04${PN}