summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-03 20:49:32 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-03 21:22:58 +0100
commit288f1e6e6930eebbfa94dcfeb70c9e7284acfa88 (patch)
treea90070398322764b5607f3f58770baccc81c88d8
parentsys-process/tini: version bump to 0.11.0 (diff)
downloadgentoo-288f1e6e.tar.gz
gentoo-288f1e6e.tar.bz2
gentoo-288f1e6e.zip
sci-mathematics/factmsieve: Revbump to EAPI=6
* Use 'python-single-r1' * Make PATCHES -p1 compliant * Fix shebang Package-Manager: portage-2.3.2
-rw-r--r--sci-mathematics/factmsieve/factmsieve-76-r1.ebuild (renamed from sci-mathematics/factmsieve/factmsieve-76.ebuild)30
-rw-r--r--sci-mathematics/factmsieve/files/factmsieve-76.patch6
2 files changed, 16 insertions, 20 deletions
diff --git a/sci-mathematics/factmsieve/factmsieve-76.ebuild b/sci-mathematics/factmsieve/factmsieve-76-r1.ebuild
index 892331aacc80..182dc5d4a263 100644
--- a/sci-mathematics/factmsieve/factmsieve-76.ebuild
+++ b/sci-mathematics/factmsieve/factmsieve-76-r1.ebuild
@@ -1,36 +1,32 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
DESCRIPTION="Convenient factorization helper script using msieve and ggnfs"
HOMEPAGE="http://gladman.plushost.co.uk/oldsite/computing/factoring.php"
SRC_URI="http://gladman.plushost.co.uk/oldsite/computing/${PN}.${PV}.zip"
-inherit eutils
-
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-# I guess no one really "needs" python 2.6, but I'm a nice person
-RDEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
+RDEPEND="${PYTHON_DEPS}
sci-mathematics/msieve
sci-mathematics/ggnfs"
DEPEND=""
-S=${WORKDIR}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}.patch"
-}
-
-src_compile() { :;
-}
+S="${WORKDIR}"
+PATCHES=( "${FILESDIR}/${P}.patch" )
src_install() {
- mkdir -p "${D}/usr/bin/"
- cp "${S}/${PN}.py" "${D}/usr/bin/${PN}" || die "Failed to install"
- chmod +x "${D}/usr/bin/${PN}" || die
+ python_fix_shebang ${PN}.py
+ dobin ${PN}.py
}
diff --git a/sci-mathematics/factmsieve/files/factmsieve-76.patch b/sci-mathematics/factmsieve/files/factmsieve-76.patch
index c22f88606588..eaf50efaecca 100644
--- a/sci-mathematics/factmsieve/files/factmsieve-76.patch
+++ b/sci-mathematics/factmsieve/files/factmsieve-76.patch
@@ -1,7 +1,7 @@
---- factmsieve.py 2010-12-02 13:59:20.000000000 +0800
-+++ factmsieve.py.new 2012-11-30 15:06:50.566116187 +0800
+--- a/factmsieve.py
++++ b/factmsieve.py
@@ -1,3 +1,4 @@
-+#!/usr/bin/env python2
++#!/usr/bin/env python
# factmsieve.py - A Python driver for GGNFS and MSIEVE
#
# Copyright (c) 2010, Brian Gladman