summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-05-25 17:07:32 +0200
committerLars Wendler <polynomial-c@gentoo.org>2022-05-25 17:08:48 +0200
commit289eb6acad7b64fa2d77685ce9273a0d96d0673f (patch)
tree35b1f92ab679ee4434c4c1160217049702290cbb
parentsys-devel/llvm: Add missing test dep on sys-apps/which (sic!) (diff)
downloadgentoo-289eb6ac.tar.gz
gentoo-289eb6ac.tar.bz2
gentoo-289eb6ac.zip
dev-libs/libbytesize: Bump to version 2.7
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-libs/libbytesize/Manifest1
-rw-r--r--dev-libs/libbytesize/libbytesize-2.7.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-libs/libbytesize/Manifest b/dev-libs/libbytesize/Manifest
index d6c8e2acba8e..0bc1e44127bc 100644
--- a/dev-libs/libbytesize/Manifest
+++ b/dev-libs/libbytesize/Manifest
@@ -1,2 +1,3 @@
DIST libbytesize-2.5.tar.gz 439194 BLAKE2B 8d2cd82cea1e95f3368eed5855abfbc89b410fe1d627f7cbe69974f0d1fc89b600c93ad242816a37c3585b8318fcce77ef0fe6ab349d10f34a8be4c69303e343 SHA512 730d9c84bfc7199424fa34de5037dd9187d60c1f32d82cedc3e395167bf39a98a3b7f20b15f154206e797144c11de05ae0f606e0af6a2157ed946f138a346ad6
DIST libbytesize-2.6.tar.gz 444795 BLAKE2B 5f89b2c614ebdd8efd3ac0841ad99c32309bdb33236373a0c9b007415a2f40ff30a0edcecb56947f2f41403cabb6a6bff68c2e4ce52e322df15d6daa3e10d2af SHA512 f6e72b763216c54c08318d090d604791c61cd5a3e683ffbe6e9d01de850661bd4e8a3adeb85c6fd0fb60244e2e128292cbae06c0aa2d1fe9f34104e64af8210e
+DIST libbytesize-2.7.tar.gz 445367 BLAKE2B de5e48b4e17364308c19bbf8e8d68f88ee9e79c9b99d77a81f9f7a1b65e09c2af0ca1ae28ac30ad1b1820335afc1aa4a2596cff487cfd770f04fda0fb38258cd SHA512 3f2bdebad1e145227d7c81b25b8832ab9f984513c35d81254f68c0cb50b1883f3b96fbb258d7c8223fb284d79dc4ec8b01beae3f7687cded629b269ef5b7210e
diff --git a/dev-libs/libbytesize/libbytesize-2.7.ebuild b/dev-libs/libbytesize/libbytesize-2.7.ebuild
new file mode 100644
index 000000000000..7b5e88e42f96
--- /dev/null
+++ b/dev-libs/libbytesize/libbytesize-2.7.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
+HOMEPAGE="https://github.com/storaged-project/libbytesize"
+SRC_URI="https://github.com/storaged-project/libbytesize/releases/download/${PV}/${P}.tar.gz"
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc python test tools"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ tools? ( python )
+"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:=
+ dev-libs/libpcre2
+ python? ( ${PYTHON_DEPS} )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-python/pocketlint[${PYTHON_USEDEP}]
+ dev-python/polib[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md )
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4-no_Werror.patch"
+)
+
+python_do() {
+ if use python ; then
+ python_foreach_impl run_in_build_dir "$@"
+ else
+ "$@"
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc gtk-doc)
+ $(use_with python python3)
+ $(use_with tools)
+ )
+ local ECONF_SOURCE="${S}"
+ python_do econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ python_do emake
+}
+
+src_test() {
+ python_do emake check
+}
+
+install_helper() {
+ emake DESTDIR="${D}" install
+ use python && python_optimize
+}
+
+src_install() {
+ python_do install_helper
+ einstalldocs
+ find "${ED}" -name "*.la" -type f -delete || die
+}