summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-02-11 16:21:32 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-02-11 16:21:53 +0100
commit28ae5ce2652cc4e1d5488034a6dd1c3d1cf26781 (patch)
treebda4939b040913f2329aeb098ddd6bd2d384d310
parentmedia-tv/kodi: 18.1_rc1 version bump (diff)
downloadgentoo-28ae5ce2652cc4e1d5488034a6dd1c3d1cf26781.tar.gz
gentoo-28ae5ce2652cc4e1d5488034a6dd1c3d1cf26781.tar.bz2
gentoo-28ae5ce2652cc4e1d5488034a6dd1c3d1cf26781.zip
www-client/firefox: use -fdisable-ipa-cdtor workaround when AVX2 is not available
This commit changes commit da3675965824a307cd16ffc48193929ba8125d98. Bug: https://bugs.gentoo.org/677052 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/firefox-65.0-r1.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/www-client/firefox/firefox-65.0-r1.ebuild b/www-client/firefox/firefox-65.0-r1.ebuild
index 56719723d0af..5fe43fe3beee 100644
--- a/www-client/firefox/firefox-65.0-r1.ebuild
+++ b/www-client/firefox/firefox-65.0-r1.ebuild
@@ -131,10 +131,7 @@ DEPEND="${CDEPEND}
# Due to a bug in GCC, profile guided optimization will produce
# AVX2 instructions, bug #677052
REQUIRED_USE="wifi? ( dbus )
- pgo? (
- lto
- !clang? ( cpu_flags_x86_avx2 )
- )"
+ pgo? ( lto )"
S="${WORKDIR}/firefox-${PV%_*}"
@@ -321,6 +318,15 @@ src_configure() {
show_old_compiler_warning=1
fi
+ if ! use cpu_flags_x86_avx2 ; then
+ # due to a GCC bug, GCC will produce AVX2 instructions
+ # even if the CPU doesn't support AVX2, https://gcc.gnu.org/ml/gcc-patches/2018-12/msg01142.html
+ einfo "Disable IPA cdtor due to bug in GCC and missing AVX2 support -- triggered by USE=lto"
+ append-ldflags -fdisable-ipa-cdtor
+ else
+ einfo "No GCC workaround required, system supports AVX2"
+ fi
+
# Linking only works when using ld.gold when LTO is enabled
mozconfig_annotate "forcing ld=gold due to USE=lto" --enable-linker=gold
fi