summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2023-02-17 17:15:08 -0500
committerRichard Freeman <rich0@gentoo.org>2023-02-17 17:15:08 -0500
commit28cb409c75552a76794814a8e9343fe0055bdf85 (patch)
treec595fbc73064f303451eec2773e7fd0223f04bfd
parentsys-libs/efivar: backport a couple fixes (diff)
downloadgentoo-28cb409c75552a76794814a8e9343fe0055bdf85.tar.gz
gentoo-28cb409c75552a76794814a8e9343fe0055bdf85.tar.bz2
gentoo-28cb409c75552a76794814a8e9343fe0055bdf85.zip
sys-process/systemd-cron: drop 1.5.18, 1.15.19
Signed-off-by: Richard Freeman <rich0@gentoo.org>
-rw-r--r--sys-process/systemd-cron/Manifest1
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.15.19.ebuild86
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.5.18.ebuild89
3 files changed, 0 insertions, 176 deletions
diff --git a/sys-process/systemd-cron/Manifest b/sys-process/systemd-cron/Manifest
index 139bd10ac7fa..44b7cf7f694b 100644
--- a/sys-process/systemd-cron/Manifest
+++ b/sys-process/systemd-cron/Manifest
@@ -1,2 +1 @@
DIST systemd-cron-1.15.19.tar.gz 33234 BLAKE2B d03c7024f9e4e569086e60908b07255e59259bc90182e34897746e1477e1b59da1934f239ef7c673e5df52c1831f07b2e759aeb7c514ba23dbbbeb780cb08a7b SHA512 90ddb3584550714a21e88a89e804511af434432b95398f325f547ee226499f8b73e153b9cdb611a11389baf434d12bc39414244b0e5e1d4565ceaac5db12b012
-DIST systemd-cron-1.5.18.tar.gz 33056 BLAKE2B a400d0169c2dcb68c91358bd2af70dca133749dab801dc87b4cdf05b8ccebe5e250466bfce93938e575aa2d832af9a4977be2f02767d2d808e45b11888277c95 SHA512 7de6a5d05ee1d73c5348ecedf6029b498b26e8cdeecce87b58f206a1719c4a90fba853eb99b860734174469c99c75a4a6fa33c13b4aac45fdc71de7f3231b9e3
diff --git a/sys-process/systemd-cron/systemd-cron-1.15.19.ebuild b/sys-process/systemd-cron/systemd-cron-1.15.19.ebuild
deleted file mode 100644
index 9a2d4907085b..000000000000
--- a/sys-process/systemd-cron/systemd-cron-1.15.19.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{9..10} )
-inherit python-single-r1 systemd
-
-DESCRIPTION="systemd units to create timers for cron directories and crontab"
-HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
-SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="cron-boot etc-crontab-systemd minutely +runparts setgid test yearly"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=sys-apps/systemd-217
- sys-apps/debianutils
- !sys-process/cronie[anacron]
- !etc-crontab-systemd? ( !sys-process/dcron )
- ${PYTHON_DEPS}
- sys-process/cronbase"
-
-DEPEND="sys-process/cronbase
- test? ( sys-apps/man-db dev-python/pyflakes )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_prepare() {
- python_fix_shebang --force "${S}/src/bin"
-
- sed -i \
- -e 's/^crontab/crontab-systemd/' \
- -e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
- -- "${S}/src/man/crontab."{1,5}".in" || die
-
- sed -i \
- -e 's!/crontab$!/crontab-systemd!' \
- -e 's!/crontab\(\.[15]\)$!/crontab-systemd\1!' \
- -e 's/pyflakes3/pyflakes/' \
- -- "${S}/Makefile.in" || die
-
- if use etc-crontab-systemd
- then sed -i \
- -e "s!/etc/crontab!/etc/crontab-systemd!" \
- -- "${S}/src/man/crontab."{1,5}".in" \
- "${S}/src/bin/systemd-crontab-generator.py" || die
- fi
-
- eapply_user
-}
-
-my_use_enable() {
- if use ${1}; then
- echo --enable-${2:-${1}}=yes
- else
- echo --enable-${2:-${1}}=no
- fi
-}
-
-src_configure() {
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --confdir="${EPREFIX}/etc" \
- --runparts="${EPREFIX}/bin/run-parts" \
- --mandir="${EPREFIX}/usr/share/man" \
- --unitdir="$(systemd_get_systemunitdir)" \
- --generatordir="$(systemd_get_systemgeneratordir)" \
- $(my_use_enable cron-boot boot) \
- $(my_use_enable minutely) \
- $(my_use_enable runparts) \
- $(my_use_enable yearly) \
- $(my_use_enable yearly quarterly) \
- $(my_use_enable yearly semi_annually) \
- $(my_use_enable setgid) \
- --enable-persistent=yes
-}
-
-pkg_postinst() {
- elog "This package now supports USE=runparts which is enabled by default."
- elog "This enables the traditional run-parts behavior."
- elog "If you disable this flag you will get the new behavior of having"
- elog "multiple jobs for each cron.* entry run in parallel with"
- elog "separate services/logs/etc."
-}
diff --git a/sys-process/systemd-cron/systemd-cron-1.5.18.ebuild b/sys-process/systemd-cron/systemd-cron-1.5.18.ebuild
deleted file mode 100644
index ec21aaf808ea..000000000000
--- a/sys-process/systemd-cron/systemd-cron-1.5.18.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{9..10} )
-inherit python-single-r1 systemd
-
-DESCRIPTION="systemd units to create timers for cron directories and crontab"
-HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
-MY_PV="1.15.18"
-SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${MY_PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-IUSE="cron-boot etc-crontab-systemd minutely +runparts setgid test yearly"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=sys-apps/systemd-217
- sys-apps/debianutils
- !sys-process/cronie[anacron]
- !etc-crontab-systemd? ( !sys-process/dcron )
- ${PYTHON_DEPS}
- sys-process/cronbase"
-
-DEPEND="sys-process/cronbase
- test? ( sys-apps/man-db dev-python/pyflakes )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_prepare() {
- python_fix_shebang --force "${S}/src/bin"
-
- sed -i \
- -e 's/^crontab/crontab-systemd/' \
- -e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
- -- "${S}/src/man/crontab."{1,5}".in" || die
-
- sed -i \
- -e 's!/crontab$!/crontab-systemd!' \
- -e 's!/crontab\(\.[15]\)$!/crontab-systemd\1!' \
- -e 's/pyflakes3/pyflakes/' \
- -- "${S}/Makefile.in" || die
-
- if use etc-crontab-systemd
- then sed -i \
- -e "s!/etc/crontab!/etc/crontab-systemd!" \
- -- "${S}/src/man/crontab."{1,5}".in" \
- "${S}/src/bin/systemd-crontab-generator.py" || die
- fi
-
- eapply_user
-}
-
-my_use_enable() {
- if use ${1}; then
- echo --enable-${2:-${1}}=yes
- else
- echo --enable-${2:-${1}}=no
- fi
-}
-
-src_configure() {
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --confdir="${EPREFIX}/etc" \
- --runparts="${EPREFIX}/bin/run-parts" \
- --mandir="${EPREFIX}/usr/share/man" \
- --unitdir="$(systemd_get_systemunitdir)" \
- --generatordir="$(systemd_get_systemgeneratordir)" \
- $(my_use_enable cron-boot boot) \
- $(my_use_enable minutely) \
- $(my_use_enable runparts) \
- $(my_use_enable yearly) \
- $(my_use_enable yearly quarterly) \
- $(my_use_enable yearly semi_annually) \
- $(my_use_enable setgid) \
- --enable-persistent=yes
-}
-
-pkg_postinst() {
- elog "This package now supports USE=runparts which is enabled by default."
- elog "This enables the traditional run-parts behavior."
- elog "If you disable this flag you will get the new behavior of having"
- elog "multiple jobs for each cron.* entry run in parallel with"
- elog "separate services/logs/etc."
-}