summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-28 12:44:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-28 14:52:32 +0100
commit28ec0709b9bb4dd6a59a8324f78cc75efd1aeca2 (patch)
treeda96c1cb22305ac2605ebe15c7ac774ee6264e5a
parentkde-plasma/plasma-firewall: 6.0.0 version bump (diff)
downloadgentoo-28ec0709b9bb4dd6a59a8324f78cc75efd1aeca2.tar.gz
gentoo-28ec0709b9bb4dd6a59a8324f78cc75efd1aeca2.tar.bz2
gentoo-28ec0709b9bb4dd6a59a8324f78cc75efd1aeca2.zip
kde-plasma/plasma-integration: 6.0.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-6.0.0.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index c8caf9628cf5..ede6251b4c32 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.27.10.tar.xz 89832 BLAKE2B 9279a29ae28d2ff8cbce6e6c9675300fba37c91b59f60c535d4f32ca54b222b2438a7e01747b864681d257cbeaf48248f4397c9d1dcd4142d4da5321fa3216a7 SHA512 a69b65cbf5cbabdb53359adb067ed673bf5582c1768aba7a6f5377f17369f95e9646e23bbac3efa0d67e12cc3705e6411e4d1a1fea1da9243937965573d12f4b
DIST plasma-integration-5.93.0.tar.xz 92968 BLAKE2B 049b268686436b6ca035a8bcf6bef014c1cdbf789ea116ddb57b0b3f865fd8d651fd89f5574379d3d7b54aaed89c65f9240b94ba1fca4ba3b3cb289f488a4d35 SHA512 e97d7911b7a8b637bdb2ee669e1b4b9bf16f1e6fc1971d18fb7950d1b328f34b43331d898efc61235a57109e3dc9f853d6cdaf9ab8ad99cc75c8ae18685cd539
+DIST plasma-integration-6.0.0.tar.xz 92988 BLAKE2B e4700de62fdd4a48baaede973b1ea82116b06074154da010717fe1b1c269532fdda3409531166c3c55360cae858e4470877a2719997a30fb13806f015057620a SHA512 547af81e99a3360a243b569e3fd70b6ffd8626eb0b3f7381eb834d487d1dd9d11de5a91111157dc51b783b04027a4a50c8b36581e0c2178f57d94ddddc35135e
diff --git a/kde-plasma/plasma-integration/plasma-integration-6.0.0.ebuild b/kde-plasma/plasma-integration/plasma-integration-6.0.0.ebuild
new file mode 100644
index 000000000000..33f9d47c4a62
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-6.0.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KF5MIN=5.113.0
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+QT5MIN=5.15.9
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="qt5"
+
+# requires running kde environment
+RESTRICT="test"
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtbase-${QTMIN}:6=[dbus,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtwayland-${QTMIN}:6
+ >=kde-frameworks/kcolorscheme-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ x11-libs/libXcursor
+ x11-libs/libxcb
+ qt5? (
+ >=dev-qt/qtdbus-${QT5MIN}:5
+ >=dev-qt/qtgui-${QT5MIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QT5MIN}:5
+ >=dev-qt/qtwayland-${QT5MIN}:5
+ >=dev-qt/qtwidgets-${QT5MIN}:5
+ >=dev-qt/qtx11extras-${QT5MIN}:5
+ >=kde-frameworks/kcompletion-${KF5MIN}:5
+ >=kde-frameworks/kconfig-${KF5MIN}:5
+ >=kde-frameworks/kconfigwidgets-${KF5MIN}:5
+ >=kde-frameworks/kcoreaddons-${KF5MIN}:5
+ >=kde-frameworks/kguiaddons-${KF5MIN}:5
+ >=kde-frameworks/ki18n-${KF5MIN}:5
+ >=kde-frameworks/kiconthemes-${KF5MIN}:5
+ >=kde-frameworks/kio-${KF5MIN}:5
+ >=kde-frameworks/kjobwidgets-${KF5MIN}:5
+ >=kde-frameworks/knotifications-${KF5MIN}:5
+ >=kde-frameworks/kwindowsystem-${KF5MIN}:5
+ >=kde-frameworks/kxmlgui-${KF5MIN}:5
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.11.1
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+ media-fonts/noto-emoji
+"
+PDEPEND="
+ >=kde-plasma/xdg-desktop-portal-kde-${PVCUT}:6
+"
+BDEPEND="
+ >=dev-qt/qtwayland-${QTMIN}:6
+ qt5? ( >=dev-qt/qtwaylandscanner-${QT5MIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_QT6=ON
+ -DBUILD_QT5=$(usex qt5)
+ )
+ ecm_src_configure
+}