summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-03-02 10:58:31 +0100
committerMichael Weber <xmw@gentoo.org>2017-03-02 18:35:29 +0100
commit28faa4f2c2d3c7604c5e581d7d569027846500b0 (patch)
tree6bec0486590e50289f9e0dea8bedff19adeb8369
parentdev-ros/rospack: Bump cmake_modules dep, bug #611412 (diff)
downloadgentoo-28faa4f2.tar.gz
gentoo-28faa4f2.tar.bz2
gentoo-28faa4f2.zip
media-libs/libasdcp-cth: Initial import (needed for dcpomatic).
Package-Manager: Portage-2.3.4, Repoman-2.3.2
-rw-r--r--media-libs/libasdcp-cth/Manifest2
-rw-r--r--media-libs/libasdcp-cth/files/libasdcp-cth-0.1.1-no-ldconfig.patch12
-rw-r--r--media-libs/libasdcp-cth/files/libasdcp-cth-0.1.2-respect-cxxflags.patch14
-rw-r--r--media-libs/libasdcp-cth/libasdcp-cth-0.1.2.ebuild25
-rw-r--r--media-libs/libasdcp-cth/libasdcp-cth-0.1.3.ebuild25
-rw-r--r--media-libs/libasdcp-cth/metadata.xml8
6 files changed, 86 insertions, 0 deletions
diff --git a/media-libs/libasdcp-cth/Manifest b/media-libs/libasdcp-cth/Manifest
new file mode 100644
index 000000000000..4e9d3e7392d9
--- /dev/null
+++ b/media-libs/libasdcp-cth/Manifest
@@ -0,0 +1,2 @@
+DIST libasdcp-cth-0.1.2.tar.bz2 636832 SHA256 062d435a767091df30614a1252a81323c097027a9d01e067b2326f76c3ffc3da SHA512 c0bcbc9dfba9ee24f67dcbfdce44cc45c6836c1ada32de6631857dc02eeb94817e591118237bc8173e47940cebac3113b4fef8a038462abb1a184a2f706ba9ab WHIRLPOOL c5a2bd3bc1f5a31e3fb9e7d5cdd513d76202a30217ed774004d8b4cf3a15e0851aa3073275411be4bfa2ba68dfb55cdad548d68085d6622e67a6c3703d8c875a
+DIST libasdcp-cth-0.1.3.tar.bz2 637004 SHA256 0a5f37fd56b8a02e176a3a2c08aa261eee836c1fef6c5d21fda7de4f40dace58 SHA512 db707a39e79ce4dcda7f20610b4fc3d1609d75dc9cc1f14a6bf7627231993882e843a3ebd9abb540a3f746c2898f94fa7bfd0617eb7c85d243585e4647e218c6 WHIRLPOOL aea95db6aeba8e7498bfc525609d53f9494abceca7facf5b2857e95af0b4960d8c3f78fcfbdccae673622f855e1dc1378a02e89515620f172c77c5e993f5308d
diff --git a/media-libs/libasdcp-cth/files/libasdcp-cth-0.1.1-no-ldconfig.patch b/media-libs/libasdcp-cth/files/libasdcp-cth-0.1.1-no-ldconfig.patch
new file mode 100644
index 000000000000..097f31ecabb3
--- /dev/null
+++ b/media-libs/libasdcp-cth/files/libasdcp-cth-0.1.1-no-ldconfig.patch
@@ -0,0 +1,12 @@
+--- libasdcp-cth-0.1.1/wscript
++++ libasdcp-cth-0.1.1/wscript
+@@ -84,8 +84,7 @@
+ bld.add_post_fun(post)
+
+ def post(ctx):
+- if ctx.cmd == 'install':
+- ctx.exec_command('/sbin/ldconfig')
++ pass
+
+ def tags(bld):
+ os.system('etags src/*.cc src/*.h')
diff --git a/media-libs/libasdcp-cth/files/libasdcp-cth-0.1.2-respect-cxxflags.patch b/media-libs/libasdcp-cth/files/libasdcp-cth-0.1.2-respect-cxxflags.patch
new file mode 100644
index 000000000000..15eeceb58423
--- /dev/null
+++ b/media-libs/libasdcp-cth/files/libasdcp-cth-0.1.2-respect-cxxflags.patch
@@ -0,0 +1,14 @@
+--- libasdcp-cth-0.1.2/wscript
++++ libasdcp-cth-0.1.2/wscript
+@@ -38,11 +38,6 @@
+ else:
+ boost_lib_suffix = ''
+
+- if conf.options.enable_debug:
+- conf.env.append_value('CXXFLAGS', '-g')
+- else:
+- conf.env.append_value('CXXFLAGS', '-O2')
+-
+ conf.check_cxx(fragment="""
+ #include <boost/version.hpp>\n
+ #if BOOST_VERSION < 104500\n
diff --git a/media-libs/libasdcp-cth/libasdcp-cth-0.1.2.ebuild b/media-libs/libasdcp-cth/libasdcp-cth-0.1.2.ebuild
new file mode 100644
index 000000000000..2ad7a280b6a8
--- /dev/null
+++ b/media-libs/libasdcp-cth/libasdcp-cth-0.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_REQ_USE="threads(+)"
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="implementation of SMPTE and the MXF Interop Sound & Picture Track File format"
+HOMEPAGE="http://carlh.net/asdcplib"
+SRC_URI="http://carlh.net/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/boost
+ dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.1.1-no-ldconfig.patch
+ "${FILESDIR}"/${PN}-0.1.2-respect-cxxflags.patch)
diff --git a/media-libs/libasdcp-cth/libasdcp-cth-0.1.3.ebuild b/media-libs/libasdcp-cth/libasdcp-cth-0.1.3.ebuild
new file mode 100644
index 000000000000..2ad7a280b6a8
--- /dev/null
+++ b/media-libs/libasdcp-cth/libasdcp-cth-0.1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_REQ_USE="threads(+)"
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="implementation of SMPTE and the MXF Interop Sound & Picture Track File format"
+HOMEPAGE="http://carlh.net/asdcplib"
+SRC_URI="http://carlh.net/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/boost
+ dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.1.1-no-ldconfig.patch
+ "${FILESDIR}"/${PN}-0.1.2-respect-cxxflags.patch)
diff --git a/media-libs/libasdcp-cth/metadata.xml b/media-libs/libasdcp-cth/metadata.xml
new file mode 100644
index 000000000000..a535b8852829
--- /dev/null
+++ b/media-libs/libasdcp-cth/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>