summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-18 22:32:17 +0000
committerSam James <sam@gentoo.org>2022-01-18 22:32:17 +0000
commit28fe1228ccd031ed24a996f9e8b86f2ebe16b375 (patch)
treeee910f9ac709654b0d4f1f5089af7e7f27b66bf9
parentdev-libs/gobject-introspection: fix build with meson 0.61 (diff)
downloadgentoo-28fe1228ccd031ed24a996f9e8b86f2ebe16b375.tar.gz
gentoo-28fe1228ccd031ed24a996f9e8b86f2ebe16b375.tar.bz2
gentoo-28fe1228ccd031ed24a996f9e8b86f2ebe16b375.zip
app-crypt/gcr: fix build with meson 0.61
Closes: https://bugs.gentoo.org/831428 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-crypt/gcr/files/gcr-3.40.0-meson-0.61-build.patch47
-rw-r--r--app-crypt/gcr/gcr-3.40.0.ebuild3
2 files changed, 49 insertions, 1 deletions
diff --git a/app-crypt/gcr/files/gcr-3.40.0-meson-0.61-build.patch b/app-crypt/gcr/files/gcr-3.40.0-meson-0.61-build.patch
new file mode 100644
index 000000000000..4bf8efbb1d73
--- /dev/null
+++ b/app-crypt/gcr/files/gcr-3.40.0-meson-0.61-build.patch
@@ -0,0 +1,47 @@
+https://gitlab.gnome.org/GNOME/gcr/-/commit/b3ca1d02bb0148ca787ac4aead164d7c8ce2c4d8.patch
+https://bugs.gentoo.org/831428
+
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Wed, 12 Jan 2022 00:24:20 +0100
+Subject: [PATCH] meson: Fix unknown kw argument in gnome.generate_gir
+
+This argument has been removed in Meson 0.61.0:
+
+ gck/meson.build:130:2: ERROR: gnome.generate_gir got unknown keyword arguments "packages"
+
+https://github.com/mesonbuild/meson/commit/f8fc5cb860465718fe7c79a1bf1fe00659f138de:
+
+> The packages argument to gnome.generate_gir was allowed, but never did anything, so stop passing it.
+
+Fixes #89
+--- a/gck/meson.build
++++ b/gck/meson.build
+@@ -131,7 +131,6 @@ if get_option('introspection')
+ sources: gck_gir_sources,
+ namespace: 'Gck',
+ nsversion: '@0@'.format(gck_major_version),
+- packages: gck_deps,
+ export_packages: 'gck-@0@'.format(gck_major_version),
+ includes: [ 'GObject-2.0', 'Gio-2.0' ],
+ header: 'gck/gck.h',
+--- a/gcr/meson.build
++++ b/gcr/meson.build
+@@ -190,7 +190,6 @@ if get_option('introspection')
+ sources: [ gcr_base_public_sources, gcr_base_headers ],
+ namespace: 'Gcr',
+ nsversion: '@0@'.format(gcr_major_version),
+- packages: gcr_base_deps,
+ export_packages: 'gcr-base-@0@'.format(gcr_major_version),
+ includes: [
+ 'GObject-2.0',
+--- a/ui/meson.build
++++ b/ui/meson.build
+@@ -152,7 +152,6 @@ if get_option('introspection')
+ export_packages: 'gcr-ui-@0@'.format(gcr_major_version),
+ identifier_prefix: 'Gcr',
+ symbol_prefix: 'gcr',
+- packages: gcr_ui_deps,
+ includes: [
+ 'GObject-2.0',
+ 'Gio-2.0',
+GitLab
diff --git a/app-crypt/gcr/gcr-3.40.0.ebuild b/app-crypt/gcr/gcr-3.40.0.ebuild
index 44c233571e9d..3a367dc36429 100644
--- a/app-crypt/gcr/gcr-3.40.0.ebuild
+++ b/app-crypt/gcr/gcr-3.40.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -46,6 +46,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/3.38.0-optional-vapi.patch
+ "${FILESDIR}"/${P}-meson-0.61-build.patch
)
pkg_setup() {