summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-17 10:49:15 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-17 10:49:15 +0200
commit2900f3b155113a7fee3b568dfec9fc3cf243472c (patch)
treeeff08eed1de0ffbc9d96e36f84e078163ce77d83
parentdev-perl/XML-Writer-0.625.0: marked ~{x86,amd64}-linux, bug #690140 (diff)
downloadgentoo-2900f3b1.tar.gz
gentoo-2900f3b1.tar.bz2
gentoo-2900f3b1.zip
app-crypt/nitrokey-app: Port to cmake.eclass
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-crypt/nitrokey-app/nitrokey-app-1.4-r1.ebuild10
-rw-r--r--app-crypt/nitrokey-app/nitrokey-app-9999.ebuild10
2 files changed, 2 insertions, 18 deletions
diff --git a/app-crypt/nitrokey-app/nitrokey-app-1.4-r1.ebuild b/app-crypt/nitrokey-app/nitrokey-app-1.4-r1.ebuild
index faf50aa87f42..0adeec0e0297 100644
--- a/app-crypt/nitrokey-app/nitrokey-app-1.4-r1.ebuild
+++ b/app-crypt/nitrokey-app/nitrokey-app-1.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils
+inherit xdg cmake
DESCRIPTION="Cross platform personalization tool for the Nitrokey"
HOMEPAGE="https://github.com/Nitrokey/nitrokey-app"
@@ -39,11 +39,3 @@ BDEPEND="
PATCHES=( "${FILESDIR}"/${P}-Make-BASH_COMPLETION_DIR-user-overridable.patch )
mycmakeargs=( -DBASH_COMPLETION_PATH=share/bash-completion/completions )
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/app-crypt/nitrokey-app/nitrokey-app-9999.ebuild b/app-crypt/nitrokey-app/nitrokey-app-9999.ebuild
index 7b3dab537ea4..ab6600e3599a 100644
--- a/app-crypt/nitrokey-app/nitrokey-app-9999.ebuild
+++ b/app-crypt/nitrokey-app/nitrokey-app-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils
+inherit xdg cmake
DESCRIPTION="Cross platform personalization tool for the Nitrokey"
HOMEPAGE="https://github.com/Nitrokey/nitrokey-app"
@@ -35,11 +35,3 @@ DEPEND="
BDEPEND="
dev-qt/linguist-tools:5
virtual/pkgconfig"
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}