summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-19 23:06:32 +0000
committerSam James <sam@gentoo.org>2022-03-19 23:33:30 +0000
commit2914a83db179802dd017b9f8dd9db32743f823aa (patch)
treeabffe4af6f7e5795c42c376564766b33131e1a40
parentmedia-plugins/tap-plugins: [QA] fix tc-get* quoting (diff)
downloadgentoo-2914a83d.tar.gz
gentoo-2914a83d.tar.bz2
gentoo-2914a83d.zip
media-plugins/vdr-xineliboutput: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r2.ebuild8
-rw-r--r--media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r4.ebuild8
-rw-r--r--media-plugins/vdr-xineliboutput/vdr-xineliboutput-9999.ebuild8
3 files changed, 12 insertions, 12 deletions
diff --git a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r2.ebuild b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r2.ebuild
index c3df9aff749c..c99f1ade06e2 100644
--- a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r2.ebuild
+++ b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,8 +11,8 @@ DESCRIPTION="VDR Plugin: Xinelib PlugIn"
HOMEPAGE="https://sourceforge.net/projects/xineliboutput/"
SRC_URI="mirror://sourceforge/${PN#vdr-}/${P}.tgz"
-SLOT="0"
LICENSE="GPL-2+"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bluray caps cec dbus fbcon jpeg libextractor nls opengl +vdr vaapi vdpau +X +xine xinerama"
@@ -83,8 +83,8 @@ src_configure() {
# No autotools based configure script
./configure \
- --cc=$(tc-getCC) \
- --cxx=$(tc-getCXX) \
+ --cc="$(tc-getCC)" \
+ --cxx="$(tc-getCXX)" \
$(use_enable X x11) \
$(use_enable X xshm) \
$(use_enable X xdpms) \
diff --git a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r4.ebuild b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r4.ebuild
index fb37a10e6c22..601a84339a77 100644
--- a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r4.ebuild
+++ b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,8 +12,8 @@ HOMEPAGE="https://sourceforge.net/projects/xineliboutput/"
SRC_URI="mirror://sourceforge/${PN#vdr-}/${P}.tgz
http://vdr.websitec.de/download/${PN}/${P}_clang.patch.bz2"
-SLOT="0"
LICENSE="GPL-2+"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bluray caps cec dbus fbcon jpeg libextractor nls opengl +vdr vaapi vdpau +X +xine xinerama"
@@ -89,8 +89,8 @@ src_configure() {
# No autotools based configure script
./configure \
- --cc=$(tc-getCC) \
- --cxx=$(tc-getCXX) \
+ --cc="$(tc-getCC)" \
+ --cxx="$(tc-getCXX)" \
$(use_enable X x11) \
$(use_enable X xshm) \
$(use_enable X xdpms) \
diff --git a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-9999.ebuild b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-9999.ebuild
index bc97c78bee09..c95ba6bb45b1 100644
--- a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-9999.ebuild
+++ b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,8 +12,8 @@ HOMEPAGE="https://sourceforge.net/projects/xineliboutput/"
EGIT_REPO_URI="https://git.code.sf.net/p/xineliboutput/git"
-SLOT="0"
LICENSE="GPL-2+"
+SLOT="0"
KEYWORDS=""
IUSE="bluray caps cec dbus fbcon jpeg libextractor nls opengl +vdr vdpau +X +xine xinerama"
@@ -93,8 +93,8 @@ src_configure() {
# No autotools based configure script
./configure \
- --cc=$(tc-getCC) \
- --cxx=$(tc-getCXX) \
+ --cc="$(tc-getCC)" \
+ --cxx="$(tc-getCXX)" \
$(use_enable X x11) \
$(use_enable X xshm) \
$(use_enable X xdpms) \