summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-01 23:52:51 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-01 23:52:51 +0200
commit295d9880d9cd001ebc35c1e2cb35884ccc0f7f59 (patch)
tree7899c1b5ed393d6cda0d31590d266b87c3e61735
parentdev-ml/lablgl: Drop 1.05-r1, EAPI5-- (diff)
downloadgentoo-295d9880d9cd001ebc35c1e2cb35884ccc0f7f59.tar.gz
gentoo-295d9880d9cd001ebc35c1e2cb35884ccc0f7f59.tar.bz2
gentoo-295d9880d9cd001ebc35c1e2cb35884ccc0f7f59.zip
net-libs/nodejs: disallow USE=lto with gcc-11+
Runtime errors + a segfault in the test suite. Bug: https://bugs.gentoo.org/787158 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-libs/nodejs/nodejs-12.22.1-r1.ebuild10
-rw-r--r--net-libs/nodejs/nodejs-14.16.1-r1.ebuild10
-rw-r--r--net-libs/nodejs/nodejs-16.0.0-r1.ebuild10
3 files changed, 27 insertions, 3 deletions
diff --git a/net-libs/nodejs/nodejs-12.22.1-r1.ebuild b/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
index aa8392c1ff25..52bbbaf58628 100644
--- a/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
@@ -59,7 +59,15 @@ pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]]; then
if use lto; then
- tc-is-gcc || die "${PN} only supports LTO for gcc"
+ if tc-is-gcc; then
+ if [[ $(gcc-major-version) -ge 11 ]]; then
+ # Bug #787158
+ die "LTO builds of ${PN} using gcc-11+ currently fail tests and produce runtime errors. Either switch to gcc-10 or unset USE=lto for this ebuild"
+ fi
+ else
+ # configure.py will abort on this later if we do not
+ die "${PN} only supports LTO for gcc"
+ fi
fi
fi
}
diff --git a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
index 02e8c08318b3..0cc7ac183eeb 100644
--- a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
@@ -54,7 +54,15 @@ pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]]; then
if use lto; then
- tc-is-gcc || die "${PN} only supports LTO for gcc"
+ if tc-is-gcc; then
+ if [[ $(gcc-major-version) -ge 11 ]]; then
+ # Bug #787158
+ die "LTO builds of ${PN} using gcc-11+ currently fail tests and produce runtime errors. Either switch to gcc-10 or unset USE=lto for this ebuild"
+ fi
+ else
+ # configure.py will abort on this later if we do not
+ die "${PN} only supports LTO for gcc"
+ fi
fi
fi
}
diff --git a/net-libs/nodejs/nodejs-16.0.0-r1.ebuild b/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
index e9e14a673451..e9b170f229d1 100644
--- a/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
+++ b/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
@@ -53,7 +53,15 @@ pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]]; then
if use lto; then
- tc-is-gcc || die "${PN} only supports LTO for gcc"
+ if tc-is-gcc; then
+ if [[ $(gcc-major-version) -ge 11 ]]; then
+ # Bug #787158
+ die "LTO builds of ${PN} using gcc-11+ currently fail tests and produce runtime errors. Either switch to gcc-10 or unset USE=lto for this ebuild"
+ fi
+ else
+ # configure.py will abort on this later if we do not
+ die "${PN} only supports LTO for gcc"
+ fi
fi
fi
}