summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-26 16:47:57 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-27 21:17:53 +0200
commit297420f23bb06600b58630662b4d055c7d8dcfac (patch)
treec354d5a8f76cee16f80e676f6bb1155b401e578c
parentsys-devel/clang: Bump to 4.0.1 (diff)
downloadgentoo-297420f2.tar.gz
gentoo-297420f2.tar.bz2
gentoo-297420f2.zip
dev-python/clang-python: Bump to 4.0.1
-rw-r--r--dev-python/clang-python/Manifest1
-rw-r--r--dev-python/clang-python/clang-python-4.0.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/clang-python/Manifest b/dev-python/clang-python/Manifest
index d66895d99ca0..e0d8ff1dc9bd 100644
--- a/dev-python/clang-python/Manifest
+++ b/dev-python/clang-python/Manifest
@@ -1 +1,2 @@
DIST cfe-4.0.0.src.tar.xz 10900916 SHA256 cea5f88ebddb30e296ca89130c83b9d46c2d833685e2912303c828054c4dc98a SHA512 a0d9972ec337a5c105fcbe7abc4076ba1e580f28908a3318f43bbfe59143f446ed5b78dad210f624145d7e5a3d56c15bfead78826c068422b60120fa1cfa482a WHIRLPOOL fe04b6955b82915bba09726947fceff92e67ffaac97de4b8c32c18546262f60a4307fdaccd3c9540710392658ed47f3bcfe44791de8d7d30786d56576f339aee
+DIST cfe-4.0.1.src.tar.xz 10933628 SHA256 61738a735852c23c3bdbe52d035488cdb2083013f384d67c1ba36fabebd8769b SHA512 936c9e1626b27e63a4fb11f3c0cb998eeaf9a520ad6e2bcd67cb4352e59e7781ecc700df79794f3fd70473d90b7e2ba418a39038eb0146b68e843f0705c1f964 WHIRLPOOL 1cb56b36e21eab8004eec43d9c0f7377588cdbcd1d654cd0e6d836d43bc68dc0759993215439c1607e09ed3fa1f68b80504a222f73c1b76d3841cdf638dcbef2
diff --git a/dev-python/clang-python/clang-python-4.0.1.ebuild b/dev-python/clang-python/clang-python-4.0.1.ebuild
new file mode 100644
index 000000000000..4f169ecc239c
--- /dev/null
+++ b/dev-python/clang-python/clang-python-4.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="http://llvm.org/"
+SRC_URI="http://releases.llvm.org/${PV/_//}/cfe-${PV/_/}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/cfe-${PV/_/}.src/bindings/python
+
+src_test() {
+ python_foreach_impl nosetests -v
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}