summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-09-26 09:50:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2017-09-26 10:03:11 -0700
commit297a8ddb8996cb2a288c36fb8859b776b0b652b7 (patch)
treed254e11394ecaf49b08cd32d430853ede8bbf29e
parentsys-block/thin-provisioning-tools: add 9999 version for testing. (diff)
downloadgentoo-297a8ddb.tar.gz
gentoo-297a8ddb.tar.bz2
gentoo-297a8ddb.zip
dev-vcs/git: make 9999 ebuilds share common code for easy of copy
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild27
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild27
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild27
-rw-r--r--dev-vcs/git/git-9999.ebuild27
4 files changed, 68 insertions, 40 deletions
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index b588ab740808..d079a65a75eb 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -7,17 +7,24 @@ GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
PYTHON_COMPAT=( python2_7 )
-[[ ${PV} == *9999 ]] && SCM="git-r3"
-# Please ensure that all _four_ 9999 ebuilds get updated; they track the 4 upstream branches.
-# See https://git-scm.com/docs/gitworkflows#_graduation
-# In order of stability:
-# 9999-r0: maint
-# 9999-r1: master
-# 9999-r2: next
-# 9999-r3: pu
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
-EGIT_BRANCH=master
PLOCALES="bg ca de fr is it ko pt_PT ru sv vi zh_CN"
+if [[ ${PV} == *9999 ]]; then
+ SCM="git-r3"
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
+ # Please ensure that all _four_ 9999 ebuilds get updated; they track the 4 upstream branches.
+ # See https://git-scm.com/docs/gitworkflows#_graduation
+ # In order of stability:
+ # 9999-r0: maint
+ # 9999-r1: master
+ # 9999-r2: next
+ # 9999-r3: pu
+ case "${PVR}" in
+ 9999) EGIT_BRANCH=maint ;;
+ 9999-r1) EGIT_BRANCH=master ;;
+ 9999-r2) EGIT_BRANCH=next;;
+ 9999-r3) EGIT_BRANCH=pu ;;
+ esac
+fi
inherit toolchain-funcs eutils elisp-common l10n perl-module bash-completion-r1 python-single-r1 systemd ${SCM}
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 01272659efb9..d079a65a75eb 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -7,17 +7,24 @@ GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
PYTHON_COMPAT=( python2_7 )
-[[ ${PV} == *9999 ]] && SCM="git-r3"
-# Please ensure that all _four_ 9999 ebuilds get updated; they track the 4 upstream branches.
-# See https://git-scm.com/docs/gitworkflows#_graduation
-# In order of stability:
-# 9999-r0: maint
-# 9999-r1: master
-# 9999-r2: next
-# 9999-r3: pu
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
-EGIT_BRANCH=next
PLOCALES="bg ca de fr is it ko pt_PT ru sv vi zh_CN"
+if [[ ${PV} == *9999 ]]; then
+ SCM="git-r3"
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
+ # Please ensure that all _four_ 9999 ebuilds get updated; they track the 4 upstream branches.
+ # See https://git-scm.com/docs/gitworkflows#_graduation
+ # In order of stability:
+ # 9999-r0: maint
+ # 9999-r1: master
+ # 9999-r2: next
+ # 9999-r3: pu
+ case "${PVR}" in
+ 9999) EGIT_BRANCH=maint ;;
+ 9999-r1) EGIT_BRANCH=master ;;
+ 9999-r2) EGIT_BRANCH=next;;
+ 9999-r3) EGIT_BRANCH=pu ;;
+ esac
+fi
inherit toolchain-funcs eutils elisp-common l10n perl-module bash-completion-r1 python-single-r1 systemd ${SCM}
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 76bcaf24d0d8..d079a65a75eb 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -7,17 +7,24 @@ GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
PYTHON_COMPAT=( python2_7 )
-[[ ${PV} == *9999 ]] && SCM="git-r3"
-# Please ensure that all _four_ 9999 ebuilds get updated; they track the 4 upstream branches.
-# See https://git-scm.com/docs/gitworkflows#_graduation
-# In order of stability:
-# 9999-r0: maint
-# 9999-r1: master
-# 9999-r2: next
-# 9999-r3: pu
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
-EGIT_BRANCH=pu
PLOCALES="bg ca de fr is it ko pt_PT ru sv vi zh_CN"
+if [[ ${PV} == *9999 ]]; then
+ SCM="git-r3"
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
+ # Please ensure that all _four_ 9999 ebuilds get updated; they track the 4 upstream branches.
+ # See https://git-scm.com/docs/gitworkflows#_graduation
+ # In order of stability:
+ # 9999-r0: maint
+ # 9999-r1: master
+ # 9999-r2: next
+ # 9999-r3: pu
+ case "${PVR}" in
+ 9999) EGIT_BRANCH=maint ;;
+ 9999-r1) EGIT_BRANCH=master ;;
+ 9999-r2) EGIT_BRANCH=next;;
+ 9999-r3) EGIT_BRANCH=pu ;;
+ esac
+fi
inherit toolchain-funcs eutils elisp-common l10n perl-module bash-completion-r1 python-single-r1 systemd ${SCM}
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index aa7cf5a5b93d..d079a65a75eb 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -7,17 +7,24 @@ GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
PYTHON_COMPAT=( python2_7 )
-[[ ${PV} == *9999 ]] && SCM="git-r3"
-# Please ensure that all _four_ 9999 ebuilds get updated; they track the 4 upstream branches.
-# See https://git-scm.com/docs/gitworkflows#_graduation
-# In order of stability:
-# 9999-r0: maint
-# 9999-r1: master
-# 9999-r2: next
-# 9999-r3: pu
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
-EGIT_BRANCH=maint
PLOCALES="bg ca de fr is it ko pt_PT ru sv vi zh_CN"
+if [[ ${PV} == *9999 ]]; then
+ SCM="git-r3"
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
+ # Please ensure that all _four_ 9999 ebuilds get updated; they track the 4 upstream branches.
+ # See https://git-scm.com/docs/gitworkflows#_graduation
+ # In order of stability:
+ # 9999-r0: maint
+ # 9999-r1: master
+ # 9999-r2: next
+ # 9999-r3: pu
+ case "${PVR}" in
+ 9999) EGIT_BRANCH=maint ;;
+ 9999-r1) EGIT_BRANCH=master ;;
+ 9999-r2) EGIT_BRANCH=next;;
+ 9999-r3) EGIT_BRANCH=pu ;;
+ esac
+fi
inherit toolchain-funcs eutils elisp-common l10n perl-module bash-completion-r1 python-single-r1 systemd ${SCM}