summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-23 11:55:07 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-31 13:46:55 +0200
commit2990366dbf3fe43fba228ef3d3701cd4b453346c (patch)
tree05d574207112c5c58727f4887f2bbc0b4552ae94
parentdev-python/zope-i18nmessageid: bump to python 3.10 (diff)
downloadgentoo-2990366d.tar.gz
gentoo-2990366d.tar.bz2
gentoo-2990366d.zip
dev-python/zope-testrunner: bump to python 3.10
fix tests for python3.10 passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zope-testrunner/files/zope-testrunner-5.3.0-fix-test-py3.10.patch64
-rw-r--r--dev-python/zope-testrunner/zope-testrunner-5.3.0.ebuild10
2 files changed, 71 insertions, 3 deletions
diff --git a/dev-python/zope-testrunner/files/zope-testrunner-5.3.0-fix-test-py3.10.patch b/dev-python/zope-testrunner/files/zope-testrunner-5.3.0-fix-test-py3.10.patch
new file mode 100644
index 000000000000..6d495ba2cf5f
--- /dev/null
+++ b/dev-python/zope-testrunner/files/zope-testrunner-5.3.0-fix-test-py3.10.patch
@@ -0,0 +1,64 @@
+From af8bfec49d90613633b76e914a6f54884463ba94 Mon Sep 17 00:00:00 2001
+From: Jerry James <loganjerry@gmail.com>
+Date: Mon, 10 May 2021 09:55:23 -0600
+Subject: [PATCH] Adapt to python 3.10 SyntaxError messages
+
+---
+ .../testrunner/tests/testrunner-debugging-import-failure.rst | 2 +-
+ src/zope/testrunner/tests/testrunner-errors.rst | 2 +-
+ src/zope/testrunner/tests/testrunner-subunit-v2.rst | 2 +-
+ src/zope/testrunner/tests/testrunner-subunit.rst | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/zope/testrunner/tests/testrunner-debugging-import-failure.rst b/src/zope/testrunner/tests/testrunner-debugging-import-failure.rst
+index 1613cb9..c0b2aee 100644
+--- a/src/zope/testrunner/tests/testrunner-debugging-import-failure.rst
++++ b/src/zope/testrunner/tests/testrunner-debugging-import-failure.rst
+@@ -41,7 +41,7 @@ Post-mortem debugging also works when there is an import failure.
+ File ".../TESTS-DIR/tests.py", line 2
+ impot doctest
+ ^
+- SyntaxError: invalid syntax
++ SyntaxError: invalid syntax...
+ > ...find.py(399)import_name()
+ -> __import__(name)
+ (Pdb) c
+diff --git a/src/zope/testrunner/tests/testrunner-errors.rst b/src/zope/testrunner/tests/testrunner-errors.rst
+index e210fe3..05d74b8 100644
+--- a/src/zope/testrunner/tests/testrunner-errors.rst
++++ b/src/zope/testrunner/tests/testrunner-errors.rst
+@@ -818,7 +818,7 @@ Then run the tests:
+ File "testrunner-ex/sample2/sampletests_i.py", line 1
+ importx unittest
+ ^
+- SyntaxError: invalid syntax
++ SyntaxError: invalid syntax...
+ <BLANKLINE>
+ <BLANKLINE>
+ Module: sample2.sample21.sampletests_i
+diff --git a/src/zope/testrunner/tests/testrunner-subunit-v2.rst b/src/zope/testrunner/tests/testrunner-subunit-v2.rst
+index 8658fe3..c165b23 100644
+--- a/src/zope/testrunner/tests/testrunner-subunit-v2.rst
++++ b/src/zope/testrunner/tests/testrunner-subunit-v2.rst
+@@ -447,7 +447,7 @@ Let's run tests including a module with some bad syntax:
+ File "/home/benji/workspace/all-the-trunks/zope.testrunner/src/zope/testrunner/testrunner-ex/sample2/badsyntax.py", line 16
+ importx unittest # noqa: E999
+ ^
+- SyntaxError: invalid syntax
++ SyntaxError: invalid syntax...
+ <BLANKLINE>
+ id=sample2.badsyntax status=fail tags=(zope:import_error)
+ id=sample2.sample21.sampletests_i status=inprogress
+diff --git a/src/zope/testrunner/tests/testrunner-subunit.rst b/src/zope/testrunner/tests/testrunner-subunit.rst
+index 6597a88..1882671 100644
+--- a/src/zope/testrunner/tests/testrunner-subunit.rst
++++ b/src/zope/testrunner/tests/testrunner-subunit.rst
+@@ -480,7 +480,7 @@ Let's run tests including a module with some bad syntax:
+ File "/home/benji/workspace/all-the-trunks/zope.testrunner/src/zope/testrunner/testrunner-ex/sample2/badsyntax.py", line 16
+ importx unittest # noqa: E999
+ ^
+- SyntaxError: invalid syntax
++ SyntaxError: invalid syntax...
+ ]
+ test: sample2.sample21.sampletests_i
+ tags: zope:import_error
diff --git a/dev-python/zope-testrunner/zope-testrunner-5.3.0.ebuild b/dev-python/zope-testrunner/zope-testrunner-5.3.0.ebuild
index 07f992c4b75a..1142107a76cd 100644
--- a/dev-python/zope-testrunner/zope-testrunner-5.3.0.ebuild
+++ b/dev-python/zope-testrunner/zope-testrunner-5.3.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -20,13 +20,17 @@ LICENSE="ZPL"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-BDEPEND="
- test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
RDEPEND="
dev-python/namespace-zope[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/zope-exceptions[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-test-py3.10.patch"
+)
distutils_enable_tests setup.py