summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2019-01-20 00:27:16 +0900
committerAkinori Hattori <hattya@gentoo.org>2019-01-20 00:27:16 +0900
commit299c2af293818d6f0b8669ba8c0d6eb1be1b08b7 (patch)
tree79aaceae76c70103673637ff95c95103beb7273d
parentapp-shells/yash: new upstream release (diff)
downloadgentoo-299c2af293818d6f0b8669ba8c0d6eb1be1b08b7.tar.gz
gentoo-299c2af293818d6f0b8669ba8c0d6eb1be1b08b7.tar.bz2
gentoo-299c2af293818d6f0b8669ba8c0d6eb1be1b08b7.zip
app-text/po4a: do not compress man pages
Closes: https://bugs.gentoo.org/675402 Signed-off-by: Akinori Hattori <hattya@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--app-text/po4a/files/po4a-man.patch18
-rw-r--r--app-text/po4a/po4a-0.47-r1.ebuild6
-rw-r--r--app-text/po4a/po4a-0.54.ebuild4
-rw-r--r--app-text/po4a/po4a-0.55.ebuild9
4 files changed, 28 insertions, 9 deletions
diff --git a/app-text/po4a/files/po4a-man.patch b/app-text/po4a/files/po4a-man.patch
new file mode 100644
index 000000000000..6dd94aed153d
--- /dev/null
+++ b/app-text/po4a/files/po4a-man.patch
@@ -0,0 +1,18 @@
+--- a/Po4aBuilder.pm
++++ b/Po4aBuilder.pm
+@@ -233,7 +233,6 @@
+ }
+ $parser->parse_from_file ($file, $out);
+
+- system("gzip -9 -f $out") and die;
+ unlink "$file" || die;
+ }
+
+@@ -245,7 +244,6 @@
+ if ($file =~ m,(.*/man(.))/([^/]*)\.xml$,) {
+ my ($outdir, $section, $outfile) = ($1, $2, $3);
+ system("xsltproc -o $outdir/$outfile.$section --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $file") and die;
+- system ("gzip -9 -f $outdir/$outfile.$section") and die;
+ }
+ unlink "$file" || die;
+ }
diff --git a/app-text/po4a/po4a-0.47-r1.ebuild b/app-text/po4a/po4a-0.47-r1.ebuild
index 94311ba3d578..dcf757c2f2b7 100644
--- a/app-text/po4a/po4a-0.47-r1.ebuild
+++ b/app-text/po4a/po4a-0.47-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -37,8 +37,10 @@ DIST_TEST="do"
PATCHES=(
# Fix bad escaping of '.' in @INC modification
- "${FILESDIR}/${PN}-0.45-614122-no-dot-inc.patch"
+ "${FILESDIR}"/${PN}-0.45-614122-no-dot-inc.patch
+ "${FILESDIR}"/${PN}-man.patch
)
+
src_prepare() {
# Check against locale files in ${S}/pod/bin for mismatches
# with languages listed in PLOCALES
diff --git a/app-text/po4a/po4a-0.54.ebuild b/app-text/po4a/po4a-0.54.ebuild
index 52fdda5fc38b..45fe4908e046 100644
--- a/app-text/po4a/po4a-0.54.ebuild
+++ b/app-text/po4a/po4a-0.54.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -33,6 +33,8 @@ DEPEND="${RDEPEND}
virtual/tex-base
)"
+PATCHES=( "${FILESDIR}"/${PN}-man.patch )
+
PERL_RM_FILES=(
t/09-html.t
)
diff --git a/app-text/po4a/po4a-0.55.ebuild b/app-text/po4a/po4a-0.55.ebuild
index 1ff6a7d4df6a..45fe4908e046 100644
--- a/app-text/po4a/po4a-0.55.ebuild
+++ b/app-text/po4a/po4a-0.55.ebuild
@@ -8,7 +8,7 @@ inherit perl-module l10n
DESCRIPTION="Tools to ease the translation of documentation"
HOMEPAGE="https://po4a.org/"
-SRC_URI="https://github.com/mquinson/po4a/releases/download/v${PV}/${P}.tar.gz"
+SRC_URI="https://github.com/mquinson/${PN}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -33,6 +33,8 @@ DEPEND="${RDEPEND}
virtual/tex-base
)"
+PATCHES=( "${FILESDIR}"/${PN}-man.patch )
+
PERL_RM_FILES=(
t/09-html.t
)
@@ -48,8 +50,3 @@ src_prepare() {
perl-module_src_prepare
}
-
-src_install() {
- perl-module_src_install
- find "${ED%/}/usr/share/man" -name '*.gz' -exec gzip -d '{}' +
-}