summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-17 00:46:13 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-17 00:49:32 +0100
commit29b381e1ce773ee916dbb10b2d8c14116e58ecca (patch)
tree1c067d4f32e77ef4ce1ed341563d9398ef86eee3
parentsys-apps/dbus: Bump to version 1.10.16 (diff)
downloadgentoo-29b381e1.tar.gz
gentoo-29b381e1.tar.bz2
gentoo-29b381e1.zip
net-dns/nsd: Bump to version 4.1.15
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--net-dns/nsd/Manifest1
-rw-r--r--net-dns/nsd/nsd-4.1.15.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index b4d76338916f..27cea0e9003e 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -1,3 +1,4 @@
DIST nsd-3.2.22.tar.gz 924627 SHA256 47c2b424c719a1535f709f4e82d796bca43cad86731f5f275c9367040a474a03 SHA512 2c0cbc97eaa376dcf496ed4323d9f7afb0dbf1852fa5fc9d8c7ecbcf8aaa1b025d56b5e439d19bc36b50deaf5f753fb08109d7e25dc1f8223fe85b7d017f81c3 WHIRLPOOL 271b47a331f2a63dd51bf642fed7083f27660f618fe0418c6b3a361d7b0a7ebda1a300d12d92c1c03e21cd17560ba4f2f2cdac76f7c6793d4befc71b66646f7d
DIST nsd-4.1.13.tar.gz 1085701 SHA256 c45cd4ba2101a027e133b2be44db9378e27602e05f09a5ef25019e1ae45291af SHA512 f355402273480b2befe914ab2e933c37ec35e5c8e747f85ba03bf8928e42ab809bb6b21cf2b8bf11e8d422a795254e1d916b154156243bc94752a01fb540525e WHIRLPOOL f5d7d3386649b82bf2f7eb6ab2f0c50b2f11e4e545931d99352a63317cda127278e5d9219763dc51a5e3a73daa0ab04e45b037eea738cad20cabf284068e9c7c
DIST nsd-4.1.14.tar.gz 1086818 SHA256 bdfc61c5f3bf11febd8f4776eef1d4f2d95ed70f12f11d4eeee943c186ffd802 SHA512 25d16a6c3e4515129f0ad4f9ab0bf6ebe12bd817cd6107d66cb99aff6b6984f5153d9b502013492cfdd907d5fad9a284583c8436b559ef4c0cce5a1176a4aff3 WHIRLPOOL 64b14e53a13ff379b665c3d76298f4616b05777694b51aa3a6541be7b2c0d6b283fe6f069dec752241393b3e8795ce048ee935f614db39d221962a2d86a693f2
+DIST nsd-4.1.15.tar.gz 1087383 SHA256 494a862cfcd26a525a4bf06306eb7ab0387b34678ac6d37767507438e3a23a4b SHA512 1011e4805d43931dd1a7fed230dadd9eb9bdf7a6728cb5bbde2def462d3bdc2ed79529ef0c60a6530e6fb78ae88a03a50d8b75b27d9130966ca20a62d8a6615e WHIRLPOOL 85a01ecb7c25e557d73e40dfbc881453020fbc20eabb50ffb47d94128e86de3861053425635b438ef86ed261dacf03a040f90d4e143726b765abc790a1c5944c
diff --git a/net-dns/nsd/nsd-4.1.15.ebuild b/net-dns/nsd/nsd-4.1.15.ebuild
new file mode 100644
index 000000000000..5c3f1296bbb3
--- /dev/null
+++ b/net-dns/nsd/nsd-4.1.15.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit user systemd
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+MY_PV=${PV/_rc/rc}
+MY_PV=${MY_PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl libressl"
+
+RDEPEND="
+ virtual/yacc
+ libevent? ( dev-libs/libevent )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ munin? ( net-analyzer/munin )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+"
+
+src_prepare() {
+ # Fix the paths in the munin plugin to match our install
+ eapply "${FILESDIR}"/nsd_munin_.patch
+ eapply_user
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-pie
+ --enable-relro-now
+ --enable-largefile
+ --with-logfile="${EPREFIX}"/var/log/nsd.log
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
+ --with-xfrdir="${EPREFIX}"/var/db/nsd
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd
+ $(use_enable bind8-stats)
+ $(use_enable bind8-stats zone-stats)
+ $(use_enable ipv6)
+ $(use_enable minimal-responses)
+ $(use_enable mmap)
+ $(use_enable nsec3)
+ $(use_enable ratelimit)
+ $(use_enable root-server)
+ $(use_enable runtime-checks checking)
+ $(use_with libevent)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED}"/run || die "Failed to remove /run"
+}
+
+pkg_postinst() {
+ # Do this in postinst to ensure the uid/gid is consistent for binpkgs
+ enewgroup nsd
+ enewuser nsd -1 -1 -1 nsd
+
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/lib/nsd
+}