summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-13 14:42:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-13 14:53:42 +0200
commit29bb064ffd1d597b934b584aac999b16d06656c3 (patch)
tree30079bec4c3fc14e2d49745293a9519a3febf9c9
parentdev-python/aiohttp: Remove old (diff)
downloadgentoo-29bb064ffd1d597b934b584aac999b16d06656c3.tar.gz
gentoo-29bb064ffd1d597b934b584aac999b16d06656c3.tar.bz2
gentoo-29bb064ffd1d597b934b584aac999b16d06656c3.zip
dev-python/selenium: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/selenium/Manifest2
-rw-r--r--dev-python/selenium/selenium-4.19.0.ebuild65
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/selenium/Manifest b/dev-python/selenium/Manifest
index c71b9ee64f1a..4249970740be 100644
--- a/dev-python/selenium/Manifest
+++ b/dev-python/selenium/Manifest
@@ -1,4 +1,2 @@
-DIST selenium-4.19.0.tar.gz 10279010 BLAKE2B f4f7761c52a38108c13d846f013eaeb54ce90ce894f3435567bf00e5b5d9ed13f71f1fcabad2ce972e098d86d3df82f1a1c5bf14ac849dcfb3378e41bc791e90 SHA512 ad4fec7dd4309478e4b53e1fdaf957230ae7c074fc77ffed6445cd80d475fd8f0f9aa88d2b732fb75b1060e03ab29257b040d95aa104b7bbaa6289ad08bb418f
DIST selenium-4.20.0.tar.gz 9307193 BLAKE2B 26d0441039776ae0c524891ed89ce2b631b2d74b561403890081ba649e1d067b841610e53d468fc2aa622fea05affd997f580e63af44256eb33dffe17b65b619 SHA512 102ce43dd9878275a80fa5e8c59162952c9ab04173c3c35f543392b31df1d600f403ad7764af76513c81df8eef5781456bf6ef2027af6a93ad99d855ab384869
-DIST selenium-selenium-4.19.0.gh.tar.gz 77053184 BLAKE2B 42319ddad80832e107acfb9f7f3dc5a18fb1779ec0910322d6c11ca9d441ce7e9992c0f7acd5c313855b33b8e67e8a2eab7736b11cd925c163fe70dee58aad44 SHA512 5e707545fdb8b38d16470988fe74b31b9040c5ff6c1958c2a500a5d20a023dedf12e321b1c60bb4d79c11cbd27e86dc2b6dc3d27b92b55759b5d9a57af526531
DIST selenium-selenium-4.20.0.gh.tar.gz 77055043 BLAKE2B 3a146a41fcebe0abb0a83b914a66252f541ab712e606166c941c08781cca92315254d3be075a988044713544909134dc7a9203ac414ba7f7985173713779e810 SHA512 1a4ee0421c8ba02fc8217792fda26bb977524531bdaaf8cb56276decdddb13adc702bd20ac195c97a7182fdd27c3a88b92a901af38c6fd059c2421e422c82768
diff --git a/dev-python/selenium/selenium-4.19.0.ebuild b/dev-python/selenium/selenium-4.19.0.ebuild
deleted file mode 100644
index 1ef3e5bed572..000000000000
--- a/dev-python/selenium/selenium-4.19.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-# upstream sometimes tags it as ${P}, sometimes as ${P}-python, sigh
-TEST_TAG=${P}
-TEST_P=selenium-${TEST_TAG}
-
-DESCRIPTION="Python language binding for Selenium Remote Control"
-HOMEPAGE="
- https://www.seleniumhq.org/
- https://github.com/SeleniumHQ/selenium/tree/trunk/py/
- https://pypi.org/project/selenium/
-"
-SRC_URI+="
- test? (
- https://github.com/SeleniumHQ/selenium/archive/${TEST_TAG}.tar.gz
- -> ${TEST_P}.gh.tar.gz
- )
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/certifi-2021.10.8[${PYTHON_USEDEP}]
- <dev-python/trio-1[${PYTHON_USEDEP}]
- >=dev-python/trio-0.17[${PYTHON_USEDEP}]
- <dev-python/trio-websocket-1[${PYTHON_USEDEP}]
- >=dev-python/trio-websocket-0.9[${PYTHON_USEDEP}]
- <dev-python/typing-extensions-5[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-4.9[${PYTHON_USEDEP}]
- <dev-python/urllib3-3[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.26[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO: we may need extra setup or deps
- test/selenium
-
- # expects vanilla certifi
- test/unit/selenium/webdriver/remote/remote_connection_tests.py::test_get_connection_manager_for_certs_and_timeout
- )
-
- cd "${WORKDIR}/${TEST_P}/py" || die
- rm -rf selenium || die
- # https://github.com/SeleniumHQ/selenium/blob/selenium-4.8.2-python/py/test/runner/run_pytest.py#L20-L24
- # seriously?
- epytest -o "python_files=*_tests.py test_*.py"
-}