summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-09-10 15:20:29 +1200
committerKent Fredric <kentnl@gentoo.org>2017-09-10 15:22:39 +1200
commit29bb345f1ea0a356c7e7e4eca3ab3bc405a7d846 (patch)
tree880a3a18b4d3c3ac188abb9f8cdef07052a768f1
parentdev-python/oauthlib: version bump to 2.0.3 (diff)
downloadgentoo-29bb345f.tar.gz
gentoo-29bb345f.tar.bz2
gentoo-29bb345f.zip
dev-perl/Bio-SamTools: Bump to version 1.430.0
- Links against samtools:0.1-legacy series, as even though this code previously attempted to use 1.0+, closer inspection indicated incomplete linking, missing symbols, and failing tests introduced by this attempt. Additionally, upstream EXPLICITLY STATE the lack of current support for samtools 1.0 - Restores DIST_TEST as I can now test they work - Fold swathe of sed commands into patch Upstream: - Ship some test files requried for tests to pass Closes: https://bugs.gentoo.org/611970 Closes: https://bugs.gentoo.org/604950 Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild33
-rw-r--r--dev-perl/Bio-SamTools/Manifest1
-rw-r--r--dev-perl/Bio-SamTools/files/Bio-SamTools-1.430.0-legacy.patch88
3 files changed, 122 insertions, 0 deletions
diff --git a/dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild b/dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild
new file mode 100644
index 000000000000..1147cec5a486
--- /dev/null
+++ b/dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=LDS
+DIST_VERSION=1.43
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Read SAM/BAM database files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="|| ( Apache-2.0 Artistic-2 GPL-1+ )"
+
+RDEPEND="
+ >=sci-biology/bioperl-1.6.9
+ sci-biology/samtools:0.1-legacy=
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/Module-Build-0.420.0
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.430.0-legacy.patch
+)
+
+src_prepare() {
+ perl-module_src_prepare
+ tc-export CC
+}
diff --git a/dev-perl/Bio-SamTools/Manifest b/dev-perl/Bio-SamTools/Manifest
index 733a42f0cc53..f379ea7e3844 100644
--- a/dev-perl/Bio-SamTools/Manifest
+++ b/dev-perl/Bio-SamTools/Manifest
@@ -1 +1,2 @@
DIST Bio-SamTools-1.42.tar.gz 337821 SHA256 ef4b736e86442ce61f56ddd94befc302ccc4646cae3c45407e107400c703584c SHA512 6a1f95104ce91a800a314c304915af9d6e1cc477c7d5f42b640d0a27b18cd32c4ad9e261cac5556f4863652570a3c573d34245963fc4b9ade067981b2a329271 WHIRLPOOL 5a216e51173ee5a9a930013718452bcbfbcffe1aa1663f50d567daf17378a50135b1b0b6d750c9aece05de268e730faf6c54963823c037559fb50ed95dda32c7
+DIST Bio-SamTools-1.43.tar.gz 340833 SHA256 7085ee5e97ad75dbbebd8583072d67b2b06d29e7a9f9741c9ac58dabe300d3fd SHA512 cd5bc6213c093f5105399c95278803afcc537bb3d191686cda0193b82fda2580749bf7533791899939a78963fcc0d6b36eabe9c309c9c6816a9849e3c892c41b WHIRLPOOL cd5ece1f08e2b4c8c64c4d289abc7a7035c18f725c28df4e9ac0319efdabb2137864b6d0b692928469c4c48010bf0ab823990a2074cef4c1a87707f5fd3f31e4
diff --git a/dev-perl/Bio-SamTools/files/Bio-SamTools-1.430.0-legacy.patch b/dev-perl/Bio-SamTools/files/Bio-SamTools-1.430.0-legacy.patch
new file mode 100644
index 000000000000..8464f06a2f01
--- /dev/null
+++ b/dev-perl/Bio-SamTools/files/Bio-SamTools-1.430.0-legacy.patch
@@ -0,0 +1,88 @@
+From 74b38ded97f7a1940c3a37b9aec9b3287a3a78bd Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 10 Sep 2017 13:33:32 +1200
+Subject: Fix linking/compiling for bam-0.1-legacy
+
+---
+ Build.PL | 6 +++---
+ c_bin/bam2bedgraph.c | 2 +-
+ c_bin/makefile | 6 +++---
+ lib/Bio/DB/Sam.xs | 6 +++---
+ 4 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/Build.PL b/Build.PL
+index 685815f..2611759 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -4,8 +4,8 @@ use strict;
+ use Module::Build;
+ use Module::Load::Conditional qw(can_load);
+
+-my $HeaderFile = "bam.h";
+-my $LibFile = "libbam.a";
++my $HeaderFile = "bam-0.1-legacy/bam.h";
++my $LibFile = "libbam-0.1-legacy.so";
+ my $ReadLine;
+
+ my ($sam_include,$sam_lib) = find_sam(); # may exit with error here
+@@ -39,7 +39,7 @@ my $build = $class->new(
+ dist_abstract => 'Perl interface to SamTools library for DNA sequencing',
+ license => 'perl',
+ include_dirs => [$sam_include],
+- extra_linker_flags => ["-L$sam_lib",'-lbam','-lpthread','-lz'],
++ extra_linker_flags => ["-L$sam_lib",'-lbam-0.1-legacy','-lpthread','-lz'],
+
+ extra_compiler_flags=>[
+
+diff --git a/c_bin/bam2bedgraph.c b/c_bin/bam2bedgraph.c
+index 298e9a8..91218fa 100644
+--- a/c_bin/bam2bedgraph.c
++++ b/c_bin/bam2bedgraph.c
+@@ -1,5 +1,5 @@
+ #include <stdio.h>
+-#include "sam.h"
++#include "bam-0.1-legacy/sam.h"
+
+ typedef struct {
+ uint32_t ltid;
+diff --git a/c_bin/makefile b/c_bin/makefile
+index 9aef917..0abbb4c 100644
+--- a/c_bin/makefile
++++ b/c_bin/makefile
+@@ -1,5 +1,5 @@
+-CC= gcc
+-CFLAGS= -g -Wall -O2 -fPIC
++CC?= gcc
++CFLAGS?= -g -Wall -O2 -fPIC
+ DFLAGS= -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_USE_KNETFILE -D_CURSES_LIB=1
+ INCLUDES=
+ LIBPATH=
+@@ -14,7 +14,7 @@ PROG= bam2bedgraph
+ all:$(PROG)
+
+ bam2bedgraph: bam2bedgraph.o
+- $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS) $(LIBPATH) -lbam -lpthread -lm -lz
++ $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS) $(LIBPATH) -lbam-0.1-legacy -lpthread -lm -lz
+
+ clean:
+ rm -f *.o $(PROG)
+diff --git a/lib/Bio/DB/Sam.xs b/lib/Bio/DB/Sam.xs
+index 023f655..86410fb 100644
+--- a/lib/Bio/DB/Sam.xs
++++ b/lib/Bio/DB/Sam.xs
+@@ -25,9 +25,9 @@
+
+ #include <unistd.h>
+ #include <math.h>
+-#include "bam.h"
+-#include "khash.h"
+-#include "faidx.h"
++#include "bam-0.1-legacy/bam.h"
++#include "bam-0.1-legacy/khash.h"
++#include "bam-0.1-legacy/faidx.h"
+
+ /* stolen from bam_aux.c */
+ #define MAX_REGION 1<<29
+--
+2.14.1
+