summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-02 20:54:41 +0100
committerSam James <sam@gentoo.org>2023-07-02 20:55:29 +0100
commit29cfe8fc0aa6d451979cb2966414451767d27491 (patch)
tree9424fe78ce97ee146d0c788837cd99b459b471c1
parentnet-analyzer/fail2ban: ignore if bad .egg-info doesn't exist (diff)
downloadgentoo-29cfe8fc0aa6d451979cb2966414451767d27491.tar.gz
gentoo-29cfe8fc0aa6d451979cb2966414451767d27491.tar.bz2
gentoo-29cfe8fc0aa6d451979cb2966414451767d27491.zip
net-analyzer/fail2ban: skip broken test
Closes: https://bugs.gentoo.org/907348 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/fail2ban/fail2ban-1.0.2-r1.ebuild2
-rw-r--r--net-analyzer/fail2ban/fail2ban-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-1.0.2-r1.ebuild b/net-analyzer/fail2ban/fail2ban-1.0.2-r1.ebuild
index 51759787dd17..9372d37e5fb4 100644
--- a/net-analyzer/fail2ban/fail2ban-1.0.2-r1.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-1.0.2-r1.ebuild
@@ -57,9 +57,11 @@ python_compile() {
}
python_test() {
+ # Skip testRepairDb for bug #907348 (didn't always fail..)
bin/fail2ban-testcases \
--no-network \
--no-gamin \
+ --ignore databasetestcase.DatabaseTest.testRepairDb \
--verbosity=4 || die "Tests failed with ${EPYTHON}"
# Workaround for bug #790251
diff --git a/net-analyzer/fail2ban/fail2ban-9999.ebuild b/net-analyzer/fail2ban/fail2ban-9999.ebuild
index 80d515fa89e4..19d76da94cf4 100644
--- a/net-analyzer/fail2ban/fail2ban-9999.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-9999.ebuild
@@ -50,8 +50,10 @@ python_prepare_all() {
}
python_test() {
+ # Skip testRepairDb for bug #907348 (didn't always fail..)
bin/fail2ban-testcases \
--no-network \
+ --ignore databasetestcase.DatabaseTest.testRepairDb \
--verbosity=4 || die "Tests failed with ${EPYTHON}"
# Workaround for bug #790251