summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-01-31 15:51:16 +0100
committerMike Gilbert <floppym@gentoo.org>2023-02-17 15:07:06 -0500
commit29d19c7c3dca617c0429b9caf1384776e35c3d81 (patch)
treecbc52edefe32b9756e266e4acd6c0691bfa959ce
parentsys-apps/systemd: add 253, drop 253_rc3 (diff)
downloadgentoo-29d19c7c.tar.gz
gentoo-29d19c7c.tar.bz2
gentoo-29d19c7c.zip
sys-process/supervise-scripts: remove daemontools from DEPEND
- daemontools are not needed for installation, only in runtime - update EAPI 7 -> 8 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/29357 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-process/supervise-scripts/supervise-scripts-4.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-process/supervise-scripts/supervise-scripts-4.0-r2.ebuild b/sys-process/supervise-scripts/supervise-scripts-4.0-r2.ebuild
new file mode 100644
index 000000000000..637c5babfaaf
--- /dev/null
+++ b/sys-process/supervise-scripts/supervise-scripts-4.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Starting and stopping daemontools managed services"
+HOMEPAGE="http://untroubled.org/supervise-scripts/"
+SRC_URI="http://untroubled.org/supervise-scripts/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/daemontools"
+
+src_prepare() {
+ echo "/usr/bin" > conf-bin
+ echo "/usr/share/man" > conf-man
+ default
+}
+
+src_install() {
+ emake PREFIX="${D}" install
+ use doc && dodoc *.html
+}