summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-22 18:22:48 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-22 18:26:12 +0100
commit29dccf7b9680688cffeab284144dfd71ada8cbd8 (patch)
tree5f6e4cd53e3fc5122116fad4045a2bcde0be3306
parentnet-dns/c-ares: Stabilize 1.25.0-r1 sparc, #922706 (diff)
downloadgentoo-29dccf7b9680688cffeab284144dfd71ada8cbd8.tar.gz
gentoo-29dccf7b9680688cffeab284144dfd71ada8cbd8.tar.bz2
gentoo-29dccf7b9680688cffeab284144dfd71ada8cbd8.zip
dev-python/fpylll: Bump to 0.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fpylll/Manifest1
-rw-r--r--dev-python/fpylll/fpylll-0.6.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/fpylll/Manifest b/dev-python/fpylll/Manifest
index 63a13560a3ef..0935cfc912b3 100644
--- a/dev-python/fpylll/Manifest
+++ b/dev-python/fpylll/Manifest
@@ -1 +1,2 @@
DIST fpylll-0.6.0.tar.gz 1084736 BLAKE2B de4fc2ef762a1dc931e728cae4857da34828fb929eec0cf05c076bce5b3f7475492871d016d94f9cac4515a04a7f652440511f4ba8f1b724c351a403d5375ea0 SHA512 e21ed21362cb9256dbc828f4d628602cd8b5c1a8640116f1c137e85056cedc89a73cab58c28ea12212ee92f4ed36b99796c5dbd30c55159baf9b33770b1a9aab
+DIST fpylll-0.6.1.tar.gz 1083895 BLAKE2B 091d757a1c64830307c0dffe10418305a625f1eceabee251a4f6d06e6fe7eb449ec85fdeb72fe8177d093c50e642e730283b0022fd70383338ca74ac6301e010 SHA512 3469c7b70cfdb0077a38f2c46c06901c4b2a1ac6db9fdab1e347c3b5ba147ee495aad56a6263d163e5f140cf9fa1591de98d01b83b92ec896092dd3e0a5d5a9b
diff --git a/dev-python/fpylll/fpylll-0.6.1.ebuild b/dev-python/fpylll/fpylll-0.6.1.ebuild
new file mode 100644
index 000000000000..3ff826c3798b
--- /dev/null
+++ b/dev-python/fpylll/fpylll-0.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for sci-libs/fplll"
+HOMEPAGE="
+ https://github.com/fplll/fpylll/
+ https://pypi.org/project/fpylll/
+"
+
+# setup.py says "or later"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/cysignals[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/fplll
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test(){
+ local -x PY_IGNORE_IMPORTMISMATCH=1
+ epytest
+}