summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-10 09:50:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-10 10:04:15 +0200
commit29dfc9a1114c2c2357f8104c7135c0eedee79ac6 (patch)
tree0b3d2d8c7b292d03dd5f0c5026f18e58382811d8
parentmedia-libs/libaom: fix shared lib underlinking (diff)
downloadgentoo-29dfc9a1.tar.gz
gentoo-29dfc9a1.tar.bz2
gentoo-29dfc9a1.zip
media-video/ffmpeg: add libaom useflag
Closes: https://bugs.gentoo.org/652824 Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild3
-rw-r--r--media-video/ffmpeg/metadata.xml1
2 files changed, 3 insertions, 1 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 04aee0a0be58..f25f8ea00468 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -92,7 +92,7 @@ FFMPEG_FLAG_MAP=(
# Same as above but for encoders, i.e. they do something only with USE=encode.
FFMPEG_ENCODER_FLAG_MAP=(
amrenc:libvo-amrwbenc mp3:libmp3lame
- kvazaar:libkvazaar nvenc:nvenc
+ kvazaar:libkvazaar libaom nvenc:nvenc
openh264:libopenh264 snappy:libsnappy theora:libtheora twolame:libtwolame
wavpack:libwavpack webp:libwebp x264:libx264 x265:libx265 xvid:libxvid
)
@@ -210,6 +210,7 @@ RDEPEND="
)
jack? ( virtual/jack[${MULTILIB_USEDEP}] )
jpeg2k? ( >=media-libs/openjpeg-2:2[${MULTILIB_USEDEP}] )
+ libaom? ( media-libs/libaom[${MULTILIB_USEDEP}] )
libass? ( >=media-libs/libass-0.10.2:=[${MULTILIB_USEDEP}] )
libcaca? ( >=media-libs/libcaca-0.99_beta18-r1[${MULTILIB_USEDEP}] )
libdrm? ( x11-libs/libdrm[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index c502f6b5f878..835207d47b64 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -30,6 +30,7 @@
<flag name="hardcoded-tables">Use pre-calculated tables rather than calculating them on the fly.</flag>
<flag name="iec61883"> Support for FireWire DV/HDV input device using <pkg>media-libs/libiec61883</pkg>.</flag>
<flag name="kvazaar">Enables <pkg>media-libs/kvazaar</pkg> based HEVC encoder.</flag>
+ <flag name="libaom">Enables <pkg>media-libs/libaom</pkg> based AV1 codec support.</flag>
<flag name="libdrm">Enables <pkg>x11-libs/libdrm</pkg> support for better screen grabbing and hardware accelerated codecs.</flag>
<flag name="libilbc">Enables iLBC de/encoding via <pkg>media-libs/libilbc</pkg>.</flag>
<flag name="librtmp">Enables Real Time Messaging Protocol using librtmp (<pkg>media-video/rtmpdump</pkg>) in addition to FFmpeg's native implementation.</flag>