summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-08-01 14:24:20 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-08-01 14:24:20 +0200
commit29e849bd76d5ab1c50940e19d6b119ce256dc45e (patch)
tree883faffda0d01d575fc2bf0cf2dd2b6b3636b87e
parentx11-terms/mlterm: add harfbuzz USE flag (diff)
downloadgentoo-29e849bd76d5ab1c50940e19d6b119ce256dc45e.tar.gz
gentoo-29e849bd76d5ab1c50940e19d6b119ce256dc45e.tar.bz2
gentoo-29e849bd76d5ab1c50940e19d6b119ce256dc45e.zip
app-emulation/kompose: Version bump to 1.0.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--app-emulation/kompose/Manifest1
-rw-r--r--app-emulation/kompose/kompose-1.0.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/kompose/Manifest b/app-emulation/kompose/Manifest
index 5a5cd698f025..06f2cb022961 100644
--- a/app-emulation/kompose/Manifest
+++ b/app-emulation/kompose/Manifest
@@ -1 +1,2 @@
DIST kompose-0.7.0.tar.gz 4980909 SHA256 6b649e91494e57ffd6c6f1d6150072d4c5589d75568172a8f3a0d6cbd7322599 SHA512 a0e8b16221ff25ca5a219646a06dd9254a87c76d5477c5a6c175e782625eb02e41c720278ec409e10f82e8c278ecd941a3d3d49b4220602fec2d3715dbf5e2a7 WHIRLPOOL 460ac6a5c3f25682ec968fef01b72c0b39a8e04cc3d3643f639010e642813a708ea6e91a74dc6d089d90aba6cece6574b83a6b515d2c11bdf9afab34491567f6
+DIST kompose-1.0.0.tar.gz 5071108 SHA256 b9c9bfc9f25c67cf7d8d8b76467487255f9882fca563f8e9ef990f647cd2406e SHA512 719b16467b1448d65319d2281a0d641342861c23e10bca204d698c7ae9ad139bee391cc5e17050bdd407b4a982aa55a3db21482225f4370976b1b5ca7fa97bdb WHIRLPOOL 35437e8a9e5ed48f7d397a79496be6dec4b62e00770453103f1746778e7df1969dd76adb81a7a029da4beb20277cff48dfa3d83c9e8bd24b902d195f5f9a9b04
diff --git a/app-emulation/kompose/kompose-1.0.0.ebuild b/app-emulation/kompose/kompose-1.0.0.ebuild
new file mode 100644
index 000000000000..dc91ae740a67
--- /dev/null
+++ b/app-emulation/kompose/kompose-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/kubernetes/kompose"
+EGIT_COMMIT="v${PV}"
+COMPOSE_COMMIT="253ec14"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Tool to move from docker-compose to Kubernetes"
+HOMEPAGE="https://github.com/kubernetes/kompose"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+RESTRICT="test"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ GOPATH="${S}" go build -ldflags="-X github.com/kubernetes/kompose/cmd.GITCOMMIT=${COMPOSE_COMMIT}" -o bin/kompose src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{docs,{README,RELEASE,ROADMAP,CHANGELOG,CONTRIBUTING}.md}
+}