summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2017-02-24 09:32:59 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2017-04-01 19:56:36 -0400
commit29f1455481e07c0de116380763f79f72342ca786 (patch)
tree32e277a30a268ab337ac7db9ce0aad47bbdc3b55
parentsys-kernel/hardened-sources: version bump to 4.9.20 (diff)
downloadgentoo-29f1455481e07c0de116380763f79f72342ca786.tar.gz
gentoo-29f1455481e07c0de116380763f79f72342ca786.tar.bz2
gentoo-29f1455481e07c0de116380763f79f72342ca786.zip
app-backup/zbackup: new ebuild
zbackup is a globally-deduplicating backup tool, based on the ideas found in rsync. Feed a large .tar into it, and it will store duplicate regions of it only once, then compress and optionally encrypt the result. Feed another .tar file, and it will also re-use any data found in any previous backups. This way only new changes are stored, and as long as the files are not very different, the amount of storage required is very low. Any of the backup files stored previously can be read back in full at any time. Base for ebuild from https://github.com/SpiderX/portage-overlay/tree/master/app-backup/zbackup Gentoo-Bug: https://bugs.gentoo.org/576796 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--app-backup/zbackup/Manifest1
-rw-r--r--app-backup/zbackup/files/zbackup-1.4.4-tartool.patch11
-rw-r--r--app-backup/zbackup/files/zbackup-9999-tartool.patch11
-rw-r--r--app-backup/zbackup/metadata.xml26
-rw-r--r--app-backup/zbackup/zbackup-1.4.4.ebuild34
-rw-r--r--app-backup/zbackup/zbackup-9999.ebuild36
6 files changed, 119 insertions, 0 deletions
diff --git a/app-backup/zbackup/Manifest b/app-backup/zbackup/Manifest
new file mode 100644
index 000000000000..9020e7f8aff7
--- /dev/null
+++ b/app-backup/zbackup/Manifest
@@ -0,0 +1 @@
+DIST zbackup-1.4.4.tar.gz 87118 SHA256 efccccd2a045da91576c591968374379da1dc4ca2e3dec4d3f8f12628fa29a85 SHA512 96f0984be71e521b2a188448bb2801996701be6e96b1dac4672cabc9f6bcb6631fdb8d03f5dde4bbdbb0050d9bd1409d468fcba15f93730d69e6c55271aba575 WHIRLPOOL 4c41f300177b3a140f833f999e5b86e8c3386e81c02a7a94f2a0dd418ba2027adb2c7906d5d2a59fba12b47c5ea3190727ef63b1e8fd12eef8bc9fbe2ca426a6
diff --git a/app-backup/zbackup/files/zbackup-1.4.4-tartool.patch b/app-backup/zbackup/files/zbackup-1.4.4-tartool.patch
new file mode 100644
index 000000000000..8f9f839a66fd
--- /dev/null
+++ b/app-backup/zbackup/files/zbackup-1.4.4-tartool.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt 2017-02-24 09:22:39.360392521 +0200
++++ b/CMakeLists.txt 2017-02-24 09:23:13.642390978 +0200
+@@ -51,4 +51,8 @@
+ ${LIBLZO_LIBRARIES}
+ )
+
++if (BUILD_TARTOOL)
++ add_subdirectory(tartool)
++endif (BUILD_TARTOOL)
++
+ install( TARGETS zbackup DESTINATION bin )
diff --git a/app-backup/zbackup/files/zbackup-9999-tartool.patch b/app-backup/zbackup/files/zbackup-9999-tartool.patch
new file mode 100644
index 000000000000..26052f97a485
--- /dev/null
+++ b/app-backup/zbackup/files/zbackup-9999-tartool.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt 2017-02-24 09:22:39.360392521 +0200
++++ b/CMakeLists.txt 2017-02-24 09:23:13.642390978 +0200
+@@ -51,4 +51,8 @@
+ ${LIBLZO_LIBRARIES}
+ )
+
++if (BUILD_TARTOOL)
++ add_subdirectory(tools/tartool)
++endif (BUILD_TARTOOL)
++
+ install( TARGETS zbackup DESTINATION bin )
diff --git a/app-backup/zbackup/metadata.xml b/app-backup/zbackup/metadata.xml
new file mode 100644
index 000000000000..65b656521136
--- /dev/null
+++ b/app-backup/zbackup/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>spiderx@spiderx.dp.ua</email>
+ <name>Vladimir Pavljuchenkov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ zbackup is a globally-deduplicating backup tool.
+ The program has the following features:
+ Parallel LZMA or LZO compression of the stored data
+ Built-in AES encryption of the stored data
+ Possibility to delete old backup data
+ Use of a 64-bit rolling hash, keeping the amount of soft collisions to zero
+ </longdescription>
+ <use>
+ <flag name="tartool">Install tartool utility</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">zbackup/zbackup</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-backup/zbackup/zbackup-1.4.4.ebuild b/app-backup/zbackup/zbackup-1.4.4.ebuild
new file mode 100644
index 000000000000..75f7cf5fca25
--- /dev/null
+++ b/app-backup/zbackup/zbackup-1.4.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A versatile deduplicating backup tool"
+HOMEPAGE="http://zbackup.org/ https://github.com/zbackup/zbackup"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="libressl tartool"
+
+DEPEND="app-arch/lzma
+ dev-libs/lzo:2
+ <dev-libs/protobuf-3:0=
+ sys-libs/zlib
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}"
+
+# Add tartool build
+PATCHES=( "${FILESDIR}/${P}-tartool.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TARTOOL="$(usex tartool)"
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-backup/zbackup/zbackup-9999.ebuild b/app-backup/zbackup/zbackup-9999.ebuild
new file mode 100644
index 000000000000..1d46d49add63
--- /dev/null
+++ b/app-backup/zbackup/zbackup-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="A versatile deduplicating backup tool"
+HOMEPAGE="http://zbackup.org/ https://github.com/zbackup/zbackup"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/${PN}/${PN}.git"
+
+LICENSE="GPL-2+-with-openssl-exception"
+KEYWORDS=""
+SLOT="0"
+IUSE="libressl tartool"
+
+DEPEND="app-arch/lzma
+ dev-libs/lzo:2
+ <dev-libs/protobuf-3:0=
+ sys-libs/libunwind:7
+ sys-libs/zlib
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}"
+
+# Add tartool build
+PATCHES=( "${FILESDIR}/${P}-tartool.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TARTOOL="$(usex tartool)"
+ )
+
+ cmake-utils_src_configure
+}