summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-04-30 07:31:55 +0200
committerHans de Graaff <graaff@gentoo.org>2024-04-30 07:49:02 +0200
commit29f86b39da1473160a3d16579b622fe875724cec (patch)
treea7907a204113e67e2a4809da82d57c346064e880
parentprofiles/arch/powerpc/ppc64: stable-mask app-emulation/libvirt[nbd] (diff)
downloadgentoo-29f86b39da1473160a3d16579b622fe875724cec.tar.gz
gentoo-29f86b39da1473160a3d16579b622fe875724cec.tar.bz2
gentoo-29f86b39da1473160a3d16579b622fe875724cec.zip
dev-ruby/httparty: add 0.22.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/httparty/Manifest1
-rw-r--r--dev-ruby/httparty/httparty-0.22.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-ruby/httparty/Manifest b/dev-ruby/httparty/Manifest
index 701567b8a496..b02f3c6b006b 100644
--- a/dev-ruby/httparty/Manifest
+++ b/dev-ruby/httparty/Manifest
@@ -1 +1,2 @@
DIST httparty-0.21.0.tar.gz 102735 BLAKE2B 131c4f3a5a403b609391ececaf079de5ed5c57ea4660fc1d1041832d8baa27b8beaf11ac2743aa6059005904d787259afec27597744bb5e35e56c3b035ca4b1b SHA512 afd50de88a6b1e1cac8c90d6e1458c41ef122b4542c3a14274aacb052f9ceafad868d1b2582d45eedd212a8037fac13238ac05c2e661c9ba9196a00ef3a0a634
+DIST httparty-0.22.0.tar.gz 102950 BLAKE2B 76dfd04997674b8932a854af72cd0be8f9c20f8835e9bbd3fa54842f2bd7b483105ec1e32e4a6bc9c9e9672c2bdd99952e57dfd6091bb0530d5900634cb94bc0 SHA512 b29b6988fc618b17b9c3d82f7450341591bb849191ee973ee6fd0d433bff79c0d95ab180d4edc24b1d7211e0b4d6fd1115ba41605282dbea6c2cea739f7dbf72
diff --git a/dev-ruby/httparty/httparty-0.22.0.ebuild b/dev-ruby/httparty/httparty-0.22.0.ebuild
new file mode 100644
index 000000000000..d232a62e274d
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.22.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="httparty.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
+HOMEPAGE="https://www.johnnunemaker.com/httparty/"
+SRC_URI="https://github.com/jnunemaker/httparty/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ dev-ruby/csv
+ >=dev-ruby/mini_mime-1.0.0
+ >=dev-ruby/multi_xml-0.5.2
+"
+
+ruby_add_bdepend 'test? ( dev-ruby/webmock )'
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files \?-\?-\?/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid test dependency on cucumber. We can't run the features since
+ # they depend on mongrel which is no longer packaged.
+ sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+
+ # Avoid test dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/pry/ s:^:#:' \
+ -e '1i require "cgi"; require "delegate"' spec/spec_helper.rb || die
+
+ # Avoid test that works standalone but fails in the suite
+ #sed -i -e '/calls block given to perform with each redirect/,/^ end/ s:^:#:' spec/httparty/request_spec.rb
+
+ # Avoid test that is not fully compatible with newer multi_xml
+ sed -i -e '/should be able parse response type xml automatically/askip "multi_xml"' spec/httparty_spec.rb || die
+
+ # Avoid test that fails due to unicode normalization differences
+ sed -i -e '/handles international domains/askip "unicode differences"' spec/httparty_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}