summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-25 05:38:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-25 05:38:06 +0200
commit29fc952994010f999f6807ed06e4871c750f01a8 (patch)
tree4109fa948740edc0018dc46fa616bd0a1d4a7156
parentdev-python/joblib: Remove old (diff)
downloadgentoo-29fc952994010f999f6807ed06e4871c750f01a8.tar.gz
gentoo-29fc952994010f999f6807ed06e4871c750f01a8.tar.bz2
gentoo-29fc952994010f999f6807ed06e4871c750f01a8.zip
dev-python/rapidfuzz: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rapidfuzz/Manifest1
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-3.7.0.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/rapidfuzz/Manifest b/dev-python/rapidfuzz/Manifest
index 9558e9af3312..5329d07dcabb 100644
--- a/dev-python/rapidfuzz/Manifest
+++ b/dev-python/rapidfuzz/Manifest
@@ -1,2 +1 @@
-DIST rapidfuzz-3.7.0.tar.gz 1569549 BLAKE2B fca22e86c002eeef7763487168d072941bbaefc7fa9cb9d5ae3d3f49e3a4487d69917da6663436cfc73ca38c67f2fc3a985e82dd64fe430aabc3708efada8513 SHA512 058fee9dc4d6934bf7b0e10eb8cc39303b6b4b67562c3b2244ec9035b1d5c3301aaf1570aa26099a6f3a6c0e7b52c387a01fcd62be28f55ab755377d053eb7f5
DIST rapidfuzz-3.8.1.tar.gz 1592462 BLAKE2B 79062be1bdd2e5aa1c364f2426a8b3cb4fc03e44b7548e475abd60827821414ce4ebcbe90377c0d19eb2c8c741e2e171c73e4672fd8126bf99856ea095e9b85b SHA512 fbebdf804220841257075af51186cde5cf8b0ea71bc4ce208bc64853fd1b1aebf97bfb86d1db058c3fb72a60268e5297fe3691b042d52263c66f8da6ae37f90a
diff --git a/dev-python/rapidfuzz/rapidfuzz-3.7.0.ebuild b/dev-python/rapidfuzz/rapidfuzz-3.7.0.ebuild
deleted file mode 100644
index 57edbabee975..000000000000
--- a/dev-python/rapidfuzz/rapidfuzz-3.7.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-# custom wrapper over setuptools
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 multiprocessing pypi
-
-DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
-HOMEPAGE="
- https://github.com/rapidfuzz/RapidFuzz/
- https://pypi.org/project/rapidfuzz/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# all these are header-only libraries
-DEPEND="
- >=dev-cpp/taskflow-3.0.0
- >=dev-cpp/rapidfuzz-cpp-3.0.2
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/cython-3[${PYTHON_USEDEP}]
- dev-python/rapidfuzz-capi[${PYTHON_USEDEP}]
- >=dev-python/scikit-build-0.16.2[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # sterilize build flags
- sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
- # remove bundled libraries
- rm -r extern || die
- # force recythonization
- find src -name '*.cxx' -delete || die
-
- distutils-r1_src_prepare
-
- export RAPIDFUZZ_BUILD_EXTENSION=1
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- # scikit-build is broken and reuses the same build
- # https://github.com/scikit-build/scikit-build/issues/633
- rm -r _skbuild || die
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
-}