summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-12 22:55:52 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-13 01:23:15 +0200
commit2a10dc0872ebdb69d92ca7daa603ac0bd68f9504 (patch)
tree15cdec0f76b3a32233a1086bc1caff33ed44ee11
parentapp-emacs/all-the-icons: disable tests (diff)
downloadgentoo-2a10dc0872ebdb69d92ca7daa603ac0bd68f9504.tar.gz
gentoo-2a10dc0872ebdb69d92ca7daa603ac0bd68f9504.tar.bz2
gentoo-2a10dc0872ebdb69d92ca7daa603ac0bd68f9504.zip
media-fonts/spleen: new package; add 2.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--media-fonts/spleen/Manifest1
-rw-r--r--media-fonts/spleen/metadata.xml17
-rw-r--r--media-fonts/spleen/spleen-2.0.0.ebuild22
3 files changed, 40 insertions, 0 deletions
diff --git a/media-fonts/spleen/Manifest b/media-fonts/spleen/Manifest
new file mode 100644
index 000000000000..8e0b13948356
--- /dev/null
+++ b/media-fonts/spleen/Manifest
@@ -0,0 +1 @@
+DIST spleen-2.0.0.tar.gz 483317 BLAKE2B 703b6017442564bbe39bbb6e3c7194c264b7c52ca898e3ca7f05f849684a4a078f4f70d82c5729f493b7aaff3bdfb6daeba225112f56cec31a733f3a1544cd0f SHA512 cae55f1f9d04995e3b6c725fb1d010b4593f6e96a9cf1b594f945f5cc827131a5c8497eb97367f8aa75dfde9841a160a5292c893f8a99bb33bc95ca67445a7a6
diff --git a/media-fonts/spleen/metadata.xml b/media-fonts/spleen/metadata.xml
new file mode 100644
index 000000000000..29337b1f0ca7
--- /dev/null
+++ b/media-fonts/spleen/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Spleen is a monospaced bitmap font for consoles and terminals. It is
+ available in 6 sizes: 5x8, 6x12, 8x16, 12x24, 16x32, and 32x64.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/fcambus/spleen/issues/</bugs-to>
+ <remote-id type="github">fcambus/spleen</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-fonts/spleen/spleen-2.0.0.ebuild b/media-fonts/spleen/spleen-2.0.0.ebuild
new file mode 100644
index 000000000000..de0696bfbeb9
--- /dev/null
+++ b/media-fonts/spleen/spleen-2.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit font
+
+DESCRIPTION="Monospaced bitmap fonts for consoles and terminals"
+HOMEPAGE="https://www.cambus.net/spleen-monospaced-bitmap-fonts/
+ https://github.com/fcambus/spleen/"
+SRC_URI="https://github.com/fcambus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( AUTHORS ChangeLog README.md )
+FONT_SUFFIX="otf pcf.gz psfu.gz"
+
+src_compile() {
+ gzip -n9 *.pcf *.psfu || die
+}